WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Call to undefined function metadata_exists() /wp-includes/capabili (17 posts)

  1. allenwhite78
    Member
    Posted 2 years ago #

    Hi all, having amassive problem with the update, set the automatic update away and it failed with the error Fatal error: Call to undefined function metadata_exists() in /home/myfolder/public_html/wp-includes/capabilities.php on line 552

    My site is down and I cannot even get to the main admin screen.

    HELP!!!!

  2. keesiemeijer
    moderator
    Posted 2 years ago #

    read the troubleshooting 3.3 master list to see if any of your problems is listed there: http://wordpress.org/support/topic/troubleshooting-wordpress-33-master-list

    try:
    - flushing any caching plugins you might be running, as well as server and/or browser caches.

    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - re-uploading all files & folders - except the wp-content folder from a fresh download of WordPress. by using FTP or whatever file management application your host provides. (manual upgrade)

  3. allenwhite78
    Member
    Posted 2 years ago #

    Thanks ill try the latter as I cant see it being theme related if I cannot get to the wp-admin. Will I need to re-upload the wp-includes aswell?

  4. jarroddaniel1
    Member
    Posted 2 years ago #

    I'm having the exact same problem with my blog. Does this mean i've lost everything on it? Or is there a way to retrieve it?

  5. keesiemeijer
    moderator
    Posted 2 years ago #

    @allenwhite78
    These are basic troubleshooting steps. It's possible that your theme is not compatible with 3.3.

    Will I need to re-upload the wp-includes aswell

    read the manual upgrade link.

    @jarroddaniel1

    Does this mean i've lost everything on it? Or is there a way to retrieve it?

    No, it means the upgrade went wrong. All the data is still in the database. Try the steps outlined in the troubleshooting 3.3 master list.

  6. jarroddaniel1
    Member
    Posted 2 years ago #

    Fatal error: Cannot redeclare get_user_metavalues() (previously declared in /home/a1257397/public_html/wp-includes/user.php:1070) in /home/a1257397/public_html/wp-includes/deprecated.php on line 2664 is the error i'm getting. I can't find the steps to fix it.

  7. jarroddaniel1
    Member
    Posted 2 years ago #

    I've re-installed it manually, and now i've just got a white screen.

  8. keesiemeijer
    moderator
    Posted 2 years ago #

    I've re-installed it manually,

    By using FTP or the file management application your host provides?

  9. jarroddaniel1
    Member
    Posted 2 years ago #

    Yes :) It's all fixed now and the website is back up and running. Thanks

  10. allenwhite78
    Member
    Posted 2 years ago #

    HI, update time, the site is up and running now, however ive issues in the dashboard if i try create a new post I see this.

    Warning: require(/home/allenwhi/public_html/wp-includes/class-wp-editor.php) [function.require]: failed to open stream: No such file or directory in /home/allenwhi/public_html/wp-includes/general-template.php on line 1808

    Fatal error: require() [function.require]: Failed opening required '/home/allenwhi/public_html/wp-includes/class-wp-editor.php' (include_path='.:/usr/lib/php:/usr/local/lib/php:/home/allenwhi/php') in /home/allenwhi/public_html/wp-includes/general-template.php on line 1808

  11. esmi
    Forum Moderator
    Posted 2 years ago #

    Try:
    - switching to the Twenty Eleven theme by renaming your current theme's folder in wp-content/themes and adding "-old" to the end of the folder name using FTP or whatever file management application your host provides.

    - resetting the plugins folder by FTP or phpMyAdmin.

    - re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    - re-running the upgrade via wp-admin/upgrade.php

  12. allenwhite78
    Member
    Posted 2 years ago #

    additionaly , i though i would run the update again, it still fails with this error..

    Warning: copy(/home/allenwhi/public_html/wp-includes/class-wp-editor.php) [function.copy]: failed to open stream: Permission denied in /home/allenwhi/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Warning: copy(/home/allenwhi/public_html/wp-includes/class-wp-editor.php) [function.copy]: failed to open stream: Permission denied in /home/allenwhi/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Could not copy file.: /home/allenwhi/public_html/wp-includes/class-wp-editor.php

  13. esmi
    Forum Moderator
    Posted 2 years ago #

    Did you re-upload all files & folders - except the wp-content folder - from a fresh download of WordPress first?

  14. allenwhite78
    Member
    Posted 2 years ago #

    Yes, as it the manual instruactions, like I said, the site is great, runs fine, access database fine , just wont do any management task. So i though I would try the auto update afgain, seems to be a permissions error...

    Warning: copy(/home/allenwhi/public_html/wp-includes/class-wp-editor.php) [function.copy]: failed to open stream: Permission denied in /home/allenwhi/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Warning: copy(/home/allenwhi/public_html/wp-includes/class-wp-editor.php) [function.copy]: failed to open stream: Permission denied in /home/allenwhi/public_html/wp-admin/includes/class-wp-filesystem-direct.php on line 200

    Could not copy file.: /home/allenwhi/public_html/wp-includes/class-wp-editor.php

  15. esmi
    Forum Moderator
    Posted 2 years ago #

    It looks like you have a permissions or ownership issue in the wp-includes folder..

  16. allenwhite78
    Member
    Posted 2 years ago #

    agreed, looking at permissions in cpanel now

  17. allenwhite78
    Member
    Posted 2 years ago #

    fixxed, these files where set to 555, i presume this will have been done by a security plugin. set to 777 then uploaded and job done, back to 555 now.

    Thanks everyone for your help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.