WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Call to undefined function is_admin() ... on line 110 (19 posts)

  1. FionaFell
    Member
    Posted 5 years ago #

    Hi,

    I am attempting to publish WP for the first time for this site, when I visit
    http://www.humephoenix.com.au/wp-admin/install.php

    I get the following error:

    Fatal error: Call to undefined function is_admin() in /home/hume/public_html/wp-admin/includes/comment.php on line 110

    As suggested to other forums participants, I have re-uploaded the full file set but that have not resolved my issue.

    Any suggestions would be welcome.

    Fiona

  2. whooami
    Member
    Posted 5 years ago #

    thats an unusual error or for you to be seeing. that file in question is there (rules out location) and i can view it (rules out permissions).

    by the way, it's actually supposed to look that way. .. at least thats what WP decided.

    http://www.humephoenix.com.au/wp-admin/gears-manifest.php

    at what point in the install process do you see that?

    for the not understanding, the undefined function is defined in the file I linked to.

  3. FionaFell
    Member
    Posted 5 years ago #

    I see that error as soon as I initiate the install script.

  4. whooami
    Member
    Posted 5 years ago #

    php version running on the server? do you know?

  5. whooami
    Member
    Posted 5 years ago #

    ack, scratch that file name in my first post.

    http://www.hume-phoenix.com.au/wp-includes/query.php

    i broke the url for you. but if you fix the domain name so its yours, you'll see that file is there too. thats actually where that undefined function is defined.

  6. FionaFell
    Member
    Posted 5 years ago #

    MySQL version 5.0.67-community
    PHP version 5.2.6

  7. FionaFell
    Member
    Posted 5 years ago #

    The error still arrives when I visit the install link above, as soon as I visit the link.

    I do not see any file query.php.

    Any more suggestions? What do I need to change?

  8. whooami
    Member
    Posted 5 years ago #

  9. FionaFell
    Member
    Posted 5 years ago #

    Yeah me too... All the files I should have are there. But the error remains? Am I missing something?

  10. whooami
    Member
    Posted 5 years ago #

    self-edit : nevermind.

  11. FionaFell
    Member
    Posted 5 years ago #

    I have this...

    // Pull in locale data after loading text domain.
    require_once(ABSPATH . WPINC . '/locale.php');

    /**

    Should I replace that with what you suggested?

  12. whooami
    Member
    Posted 5 years ago #

    you read my "before edit" .. but okay, lets run with that. does your wp-config.php NOT look like this one at the bottom?

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'putyourdbnamehere');    // The name of the database
    define('DB_USER', 'usernamehere');     // Your MySQL username
    define('DB_PASSWORD', 'yourpasswordhere'); // ...and password
    define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    
    // Change each KEY to a different unique phrase.  You won't have to remember the phrases later,
    // so make them long and complicated.  You can visit http://api.wordpress.org/secret-key/1.1/
    // to get keys generated for you, or just make something up.  Each key should have a different phrase.
    define('AUTH_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    define('SECURE_AUTH_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    define('LOGGED_IN_KEY', 'put your unique phrase here'); // Change this to a unique phrase.
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    /* That's all, stop editing! Happy blogging. */
    
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    if not, it needs to.

    --

    are you uploading the files with dreamweaver? if so, dont. grab a plain old ftp client and reupload with that.

  13. FionaFell
    Member
    Posted 5 years ago #

    wp-config.php

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'hume_phoenix'); // The name of the database
    define('DB_USER', 'hume_hume'); // Your MySQL username
    define('DB_PASSWORD', 'passwordgoeshere'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    /* That's all, stop editing! Happy blogging. */

    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');
    require_once(ABSPATH . 'wp-settings.php');
    ?>

    Uploading using FileZilla

  14. FionaFell
    Member
    Posted 5 years ago #

    Looks like it is a match to what should be there?

  15. FionaFell
    Member
    Posted 5 years ago #

    Any other suggestions perhaps?

    I am at a loss for where to look next.

  16. FionaFell
    Member
    Posted 5 years ago #

    I deleted all content from the server, and re-published again using FileZilla like previous attempts, and the error remains when I visit the setup/intall URL.

  17. FionaFell
    Member
    Posted 5 years ago #

    RESOLVED my issue. I am gonna pay a WP Pro to install for me. Thanks.

  18. ben_faulkner
    Member
    Posted 4 years ago #

    can you tell me how you resolved this please? im having the same think :-(

  19. PixelMonkey
    Member
    Posted 4 years ago #

    After receiving this same error and spending a bunch of time tracing it I discovered that it was somehow related to a "hiccup" in the FTP upload process. I put an "echo" statement in the query.php file located in the wp-includes subdirectory (this is where the is_admin() function is defined).

    As soon as I uploaded the edited file everything worked (well not really because I had to remove the ECHO statement first).

    My suggestion is to re-upload the query.php file and try again.

    After tracing all the code prior to the error I can attest that the code is solid. The problem was definitely due to the uploaded file not being quite 100%. Why that didn't throw an error when it got called is beyond me.

    Hope this saves time for the next shlep like me who comes along with this issue.

Topic Closed

This topic has been closed to new replies.

About this Topic