WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Fatal error: Call to undefined function get_current_screen() (10 posts)

  1. dianaascher
    Member
    Posted 1 year ago #

    Seems this is an error related to WP eCommerce. Are you planning to fix this, or should I look at other plugins? I'd prefer not to have to set everything up again and to stick with WP eCommerce!

    http://wordpress.org/support/topic/fatal-error-call-to-undefined-function-get_current_screen-1?replies=9#post-4381407

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    If you're able to edit the plugin, open up the /wpsc-admin/display-items.page.php file, go to Line 490, and modify it to look like this

    if ( ! is_admin() || ( defined( 'DOING_AJAX' ) && DOING_AJAX ) || ! $query->is_main_query() )

    That should fix your issues. In fact, that was in our master branch on GitHub about a month ago - so I'm still a bit baffled at how we missed it in the 3.8.12 release - also baffled as to why some people experience this, and others (myself included) do not.

    Either way, that fix should do it for you! Let me know if it doesn't.

  3. yunck
    Member
    Posted 1 year ago #

    I have tried really hard to like wp ecommerce for a couple of years now, as it has so many features compared to other shopping cart plugins, and have constantly hoped that it would get better. I have persisted with hacks and spent countless hours learning how to modify it, as I always thought that it was only going to be a matter of time before the bugs get blown out and it cleans itself up. I really thought it was getting better, but when I install the latest version of it and get a fatal error on every page which is clearly the fault of wp ecommerce, then find your fix (thanks by the way, it worked) and your comment shows that this error has been known about for a month, I start losing faith again.

    Are you guys introducing new bugs at the same rate as you are getting rid of the old ones, or is it actually getting better? I am not trying to make a joke - I am actually confused about where it is going.

    If you can suggest to me a paid plugin that does pretty much what wp ecommerce does I will gladly pay. the problem is, I actually cant find one. No matter how hard I google, as soon as I think I have found an alternative, someone in the discussion highlights a big functional hole that it doesnt have and I go dang! Looks like I have to keep sticking with wp ecommerce.

    Do you konw of any other alternative? Pleaaaase?

    As soon as I got this error immediately on install, I just went back to thinking this plugin is not getting any better.

    Tell me, seriously, what else is there that I would gladly pay up to $200 for which does the same thing? Anyone?

  4. ricky88
    Member
    Posted 1 year ago #

    @yunck - yes you should have a look at WooCommerce, it has everything WPEC has and more and the code is way more solid than WPEC. Way less bugs and is also more active with more regular updates...

  5. yunck
    Member
    Posted 1 year ago #

    I did look at woocommerce once - I watched a video comparing woocommerce vs WPEC, and the problem was that woocommerce did not have the same capabilities as WPEC when it came to product variations.

    @ricky88 - would you agree that variations are a limitation in woocommerce compared to WPEC?

  6. Justin Sainton
    Member
    Plugin Author

    Posted 1 year ago #

    @yunck - I'd be happy to help you resolve your issues - have you tried modifying the code as mentioned above in this thread?

  7. yunck
    Member
    Posted 1 year ago #

    HI Justin,
    If you read my first comment around line 7 you will see that I applied your fix and thanked you because it worked. My issues are about the bigger picture with wp ecommerce and how i hesitate to offer my clients a plugin that is just not proving itself sufficiently stable despite my hopes over a two year period that it would become so.

    Going forward, I dont want to keep googling advice like yours to put the fires out as it is too risky - one day I just might have an angry client with a fire, and your advice just might not be there then.

    That is where I am really coming from.

    @ricky88 - It seems that Woocommerce does do variations, and I think I will download it and really suss it out fully. Thanks for your advice.

  8. ricky88
    Member
    Posted 1 year ago #

    @yunck - you won't regret and you won't ever look back...Its a much superior product than WPEC...don't get me wrong WPEC was once great but has not moved forward in a long while even with the latest updates, the code base is still messy and full of bugs.

  9. yunck
    Member
    Posted 1 year ago #

    I have been watching woocommerce videos since my last comment so Im there baby. You know, the BIG clincher for me already is that a real sticking point with WPEC is that it does not have a widget where the shopper can sort by price-asc or price-desc, and I have seen that feature on stores everywhere. You can specify this in the admin, but that is too static. The shopper needs to be able to sort the results while shopping - it is a pretty basic need that people want to suss out their results with a bit of sorting such as cheapest to most expensive or vice versa.

    Strangely, there is no widget for it, or any advice anywhere and people on elance are asking for it everywhere. I asked the WPEC team for it once and it went no where. I found someones code that did it, but only on the main prod page, not when sorted by category. Aaah.

    Then walla - woocommerce has it. I think I am about to be converted. This might seem like a minor feature to make a big deal about, but when you think about it, it is quite a major part of useability.

    Thanks again ricky88 and justin for your advice on both situations.

  10. rikboy
    Member
    Posted 11 months ago #

    Hello,

    Just in case you still want to use WPEC

    1. Open "wp-content/plugins/wp-e-commerce/wpsc-admin/admin.php"
    2. After Line #26: Add "require_once(ABSPATH . 'wp-admin/includes/screen.php');"
    3. Save your changes... and see if bug still exists.

    Goodluck :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic