WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal Error: Call to function - Multisite (12 posts)

  1. Sim23_10
    Member
    Posted 2 years ago #

    I am getting the error - Fatal error: Call to undefined function get_the_post_thumbnail() in /home/warrior/public_html/wp-content/themes/earth-warrior/page.php on line 18

    i removed line 18 to see if it came back but it just came up with the same message but for a different function. The function files in wp-includes i haven't touch and the default themes seem to be working fine so that says that the issue is with my custom theme.

    downloaded my custom theme from the ftp and installed it on a local MAMP installation - works perfect...

    can someone suggest a course of action/investigation.

    thanks

    http://earth-warrior.com/ice-warrior/

  2. Sim23_10
    Member
    Posted 2 years ago #

    ps. have tried deactivating all plugins but still get the error.

  3. esmi
    Forum Moderator
    Posted 2 years ago #

    Are you absolutely sure that you are using WordPress 3.3.1?

  4. Sim23_10
    Member
    Posted 2 years ago #

    yeah I am.

  5. esmi
    Forum Moderator
    Posted 2 years ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

  6. Sim23_10
    Member
    Posted 2 years ago #

    ok, will get back to you as to how it goes.

  7. FWIW, just because something works perfectly in Localhost doesn't always mean it'll work out in the wild.

    You should also make 100% sure you have the whole theme uploaded, and that it doesn't have any goofy calls to localhost in it.

  8. Sim23_10
    Member
    Posted 2 years ago #

    Has been working fine in the wild for the last 3 weeks while it underwent testing and content submission. Just tonight that it came up with that error for no logical reason (no updates etc)

  9. Sim23_10
    Member
    Posted 2 years ago #

    mmm after re adding all the files I am getting the hosts 404 page when trying to access the network sites but i can get to the respective dashboards?

  10. Sim23_10
    Member
    Posted 2 years ago #

    gaah no help wordpress reinstalled and the same issue

  11. Sim23_10
    Member
    Posted 2 years ago #

    my guess is somehow it's not calling twenty eleven. in localhost i get the twenty eleven theme options with my custom theme, online i don't.

  12. Sim23_10
    Member
    Posted 2 years ago #

    this was the problem - a stray character in the calling of twenty eleven in the child themes css, doesn't explain why it worked locally but sorted now

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.