WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] "Fatal error" but still posting (2 posts)

  1. davincim
    Member
    Posted 7 years ago #

    When I posted to my blog this evening I had this strange error message pop up (it was right after I posted my article):

    Fatal error: Call to undefined function: the_keywords() in /hsphere/local/home/galen5/familywebwatch.com/blog/wp-content/themes/Blix/header.php on line 8

    Line 8 reads:

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen, projection" />

    Oddly enough though, the article got posted to my blog. Never seen this one before I upgraded to 2.04 and not sure what to make of this.

    The other thing I was experiencing had to do with my head_meta plugin. I entered the values like I always had before and got an error (but didn't think fast enough to copy it for analysis here!). Thinking I needed to refresh, I did so three times. When I finally got back to the Write screen for that article, there were three instances of the same meta data I entered. Clicking the delete button next to each gave me an error (again, forgot to copy), but after refreshing another time, it managed to go away.

    Your help is appreciated. :)

  2. davincim
    Member
    Posted 7 years ago #

    Oh wait! I found the solution. User error, sort of.

    I was looking at an older version of the file I thought I was editing. Line 8 was really something else related to a plugin. When I deactivated that plugin, the code cried. Once I removed that line of code, my page displayed happily.

    Sorry for the false alarm.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags