WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
[resolved] Fatal Error - Better WP Security (23 posts)

  1. Big_Rich
    Member
    Posted 1 year ago #

    Hi,

    I've just noticed the following error message displayed on the right hand side of the backend for Better WP security (below the donate and Need Help boxes)

    Fatal error: Call to undefined method WP_Error::get_items() in ***********hidden********/plugins/better-wp-security/lib/bit51/bit51.php on line 353

    I'm using WP 3.5.1 and Better WP Security 3.4.9 build version 3059

    The front end site seems to be OK

    I've done the following to try to fix it:

    Deactivate all other plugins
    Activate default theme (2012)
    Uncheck all the teweaks which are known to possibly cause conflicts

    Unfortunately the error persits.

    I've done a search and found 2 other threads which talk about the same problem but unfortunately no solution indicated.

    Is there a solution to this problem please?

    Server Info:
    MySQL Database Version: 5.1.67-log
    MySQL Client Version: 5.1.66
    Server Type: Apache
    Operating System: Linux
    PHP Version: 5.4.12

    Thanks in advance for your help

    http://wordpress.org/extend/plugins/better-wp-security/

  2. karenclark
    Member
    Posted 1 year ago #

    I've got this same problem. Is it a problem?

  3. abuczynski
    Member
    Posted 1 year ago #

    I have exactly the same problem with the same specs as Big_Rich.

  4. SASFOR
    Member
    Posted 1 year ago #

    ditto
    On All the 10 sites I have installed on.

    + there seems to be a log out problem- any one noticed that ?

    Fatal error: Call to undefined method WP_Error::get_items() in **************************wp-content/plugins/better-wp-security/lib/bit51/bit51.php on line 353

    Please help
    Thank you in advance
    vivi

  5. abuczynski
    Member
    Posted 1 year ago #

    In my case I don't have a log out problem.

    Just that fatal error message on the right hand side appearing regardless of which sub-menu item I'm in within the BWS.

    AB

  6. Graham
    Member
    Posted 1 year ago #

    The line 353 is pulling the feed of the last 5 topics from BWPS.

    Obviously something has gone wrong with their feed setup. The error will not affect our own blogs, or how they operate, from what I can see.

    Visitors will not see any site error messages when going to your blog.

  7. Big_Rich
    Member
    Posted 1 year ago #

    Thanks very much for your reply Graham.

    That makes sense because I've checked line 353and its this:

    /**
    		 * Display Bit51's latest posts
    		 *
    		 * Displays latest posts from Bit51 in admin page sidebar
    		 *
    		 **/
    		function news() {
    
    			include_once( ABSPATH . WPINC . '/feed.php' ); //load WordPress feed info
    
    			$feed = fetch_feed( $this->feed ); //get the feed
    
    			$feeditems = $feed->get_items( 0, $feed->get_item_quantity( 5 ) ); //narrow feed to last 5 items
    
    			$content = '<ul>'; //start list
    
    			if ( ! $feeditems ) {
    
    			    $content .= '<li class="bit51">' . __( 'No news items, feed might be broken...', $this->hook ) . '</li>';
    
    			} else {
    
    				foreach ( $feeditems as $item ) {
    
    					$url = preg_replace( '/#.*/', '', esc_url( $item->get_permalink(), $protocolls = null, 'display' ) );
    
    					$content .= '<li class="bit51"><a class="rsswidget" href="' . $url . '" target="_blank">'. esc_html( $item->get_title() ) .'</a></li>';
    
    				}
    
    			}	
    
    			$content .= '</ul>'; //end list
    
    			$this->postbox( 'bit51posts' , __( 'The Latest from Bit51', $this->hook ), $content ); //set up postbox
    
    		}

    Thanks again for putting my mind at rest !

  8. theresajennings2011
    Member
    Posted 1 year ago #

    This really should get fixed. I'm having the same issue.

  9. dpolcino
    Member
    Posted 1 year ago #

    Same issue. It's happening on two sites made with iThemes Builder. Then I have a site made with Headway and that one does NOT show the error. So this is bad because it's a fatal error, but is the consensus that it really isn't that big of a deal?

  10. Big_Rich
    Member
    Posted 1 year ago #

    @ dpolcino

    On your site which doesn't have the problem,

    Can you see the feeds, or just you don't get the error message?

  11. dpolcino
    Member
    Posted 1 year ago #

    All feeds on all sites seem fine. I just don't get the error message on the headway site.

  12. mbrsolution
    Member
    Posted 1 year ago #

    Hello all, I don't have any errors in my installation. I am running this plugin on all my websites without any problems or errors.

    I am using WordPress 3.5.1, WP Security 3.4.9 and my theme is Suffusion.

    Server Info:
    MySQL Database Version: 5.5.30-log
    MySQL Client Version: 5.5.30
    Server Type: Apache
    Operating System: Linux
    PHP Version: 5.2.17

    I hope this helps in some way.

    Kind regards

  13. nick1900
    Member
    Posted 1 year ago #

    I'm getting the same error on sites built with Pagelines 2.6.1 and WP 3.5.1. However, it doesn't appear to impact the functionality.

  14. Graham
    Member
    Posted 1 year ago #

    An update has been released that has fixed the problem.

  15. SASFOR
    Member
    Posted 1 year ago #

    Thank you Graham for the update .
    Will try WP yet again with "Better WP Security".

    I say Yet again, as I had to delete all 10 + WP sub domains!As I was having big time Front End issues too. Including Admin Log Outs and page loading on the front end. Have already migrated to an other platform all together !

    Yes I deleted all plugins including Jet Pack, to avail. The moment I deleted "Better WP Security" I was able to temporarily some control of my sub domains.

    Having said that I am a great WP fan and I believe the "Better WP Security" is one of the Best Conceived and executed Plugs- Simplicity and the complexity that come with power are a hard to find combo and BWPS manages these elements admirably .

    As such Will give WP and BWPS an other twirl.

    Thank you for the update.
    vivi

  16. Graham
    Member
    Posted 1 year ago #

    Don't get me wrong, I have no connection with BWPS. I was just letting people know they've fixed the problem.

  17. SASFOR
    Member
    Posted 1 year ago #

    @ Graham

    I understand that. Was just thanking you for the update. As there is no "official" word out on it so far, apart from a newer version :)

    + was letting other users know about the issues I was facing

    vivi

  18. Big_Rich
    Member
    Posted 1 year ago #

    Yep, just installed the new update and the error message is gone and the feeds are showing.

    Thank you BIT 51

  19. SASFOR
    Member
    Posted 1 year ago #

    @ Big_Rich
    Sounds Good.

    Testing.
    rgds
    vivi

  20. SASFOR
    Member
    Posted 1 year ago #

    testing on a new Sub Domain [Live] with no other plug activated including Jet Pack and Akismet.

    Will update all about the status.
    vivi

  21. SASFOR
    Member
    Posted 1 year ago #

    Isolated the issue [I think]the issue seems to be when you click "Change Database Prefix" , your browser will tell you " No Data Received" !!

    Refresh the page and bingo you have your new Database Prefix!!

    Request the developers to note that this IS a fresh WP install. With NO other Plugs activated.

    regards
    vivi

    PS: Developers Please Wake UP.

    [Please be patient. This a forum - not online chat!]

  22. SASFOR
    Member
    Posted 1 year ago #

    Deleted BWPS and can not access my admin !!!

    Yest again I have wasted my time. Deleting this plug from my host end as I can not access my admin any more!

    Maybe BWPS should carry the acronym BS??

    This is beyond wasting time and energy
    vivi

  23. SASFOR
    Member
    Posted 1 year ago #

    Apologies
    [Please be patient. This a forum - not online chat!]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.