WordPress.org

Ready to get started?Download WordPress

Forums

Google Site Verification Plugin
Fatal error at activation (8 posts)

  1. reeds_boats
    Member
    Posted 3 years ago #

    I have successfully installed the Official Google Site Verification plugin, however I get a fatal error when trying to activate it:

    Fatal error: Call to undefined function sys_get_temp_dir() in /var/www/vhosts/boatreeds.com/httpdocs/WP/wp-content/plugins/official-google-site-verification-plugin/external/php-client/config.php on line 53

    Can you please advise?
    Thanks,
    Linda

  2. kbm
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Linda,

    Which version of PHP are you using?

    This plugin is using functionality that was introduced in PHP 5.2.1. Your version of PHP must be older than that. Hopefully you don't have a version older than 5.2.0, because we do not support versions of PHP that are older than that.

    I made a fix that will allow the plugin to run on 5.2.0. Assuming your version of PHP is at version 5.2.0 or above, you can try again in an hour or so.

    Kevin

  3. kharlo
    Member
    Posted 3 years ago #

    Hi Kevin,
    I have this error on activation:
    The Google PHP API Library needs the CURL PHP extension

    I have PHP v5.2.0-8+etch15
    what should I do?

    thanks!
    kharlo

  4. kbm
    Member
    Plugin Author

    Posted 3 years ago #

    Do you have root access to your system? You might need to recompile PHP to include CURL support, or install additional support packages (e.g. php5-curl on Ubuntu.)

  5. kharlo
    Member
    Posted 3 years ago #

    no access... i'm in hosting...

  6. kbm
    Member
    Plugin Author

    Posted 3 years ago #

    Hello Kharlo,

    Sorry, the plugin won't work unless your hoster upgrades your PHP installation to support libcurl.

    Fortunately, the plugin is not the only way to verify your site with Google. There are several manual verification methods you can use to verify your blog at https://www.google.com/webmasters/verification/ .

    There are also several other verification plugins available for WP that don't rely on web service calls, and therefore shouldn't require CURL libraries.

    I hope that helps!

  7. chicagorealtor
    Member
    Posted 2 years ago #

    Can someone help me with this error message? I am using PHP 5.0

    Fatal error: Uncaught exception 'apiCacheException' with message 'Could not create storage directory: /tmp/apiClient/2d' in /home/haberdas/public_html/wp-content/plugins/official-google-site-verification-plugin/external/php-client/cache/apiFileCache.php:117 Stack trace: #0 /home/haberdas/public_html/wp-content/plugins/official-google-site-verification-plugin/external/php-client/auth/apiOAuth.php(90): apiFileCache->set('OAuth:anonymous...', '0DiY7kh4IaLBviK...') #1 /home/haberdas/public_html/wp-content/plugins/official-google-site-verification-plugin/external/php-client/apiClient.php(138): apiOAuth->authenticate(Object(apiFileCache), Object(apiCurlIO), Array) #2 /home/haberdas/public_html/wp-content/plugins/official-google-site-verification-plugin/googleSiteVerification.php(87): apiClient->authenticate() #3 [internal function]: google_admin_head('') #4 /home/haberdas/public_html/wp-includes/plugin.php(405): call_user_func_array('google_admin_he...', Array) #5 /home/haberdas/public_html/wp-admin/admin.php(111): do_action('a in /home/haberdas/public_html/wp-content/plugins/official-google-site-verification-plugin/external/php-client/cache/apiFileCache.php on line 117

    Thank You!

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    FTP into your site (or use whatever file management application your host provides) and delete the wp-content/plugins/official-google-site-verification-plugin folder.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic