WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Fatal error: Allowed memory size when W3 Total Cache is active in wp-admin area (6 posts)

  1. twoelevenjay
    Member
    Posted 9 months ago #

    Hello and thank you in advance for anyone that might have some insight on this to offer.

    I have had W3 Total Cache activated for 3 days and everything was fine. All of a sudden late last night the backend of WordPress became unavailable with the PHP fatal error:

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 1819840 bytes) in...

    When I remove:

    db.php
    object-cache.php
    advanced-cache.php

    from the wp-content folder, wp-admin becomes accessible again. Except a few of the meta boxes on the dashboard show this error instead of their data (i.e. the plugin meta box). If an action from W3 Total Cache is initiated it recreates the three files mentioned above and wp-admin becomes unavailable again (this even happens from trying to deactivate the plugin from the plugin screen. When I deactivate it by changing the directory name via FTP everything returns to normal.

    An important thing to mention is that most Google search results for this error talk about the memory limit:

    define( 'WP_MEMORY_LIMIT', '64M' );

    However my WP_MEMORY_LIMIT is set to 64M and the number 134217728 bytes equals 128M. The only thing I have set to 128M is PHP Post Max Size.

    I suspect this is not actually the fault of W3 Total Cache alone. The site is running WPML, WooCommerce and several other heavy plugins.

    If anyone can help point me in the correct direction that would be great. I could increase PHP Post Max Size but I don't think I should have to.

    W3 Total Cache is AWESOME. I would love to learn everything there is to know about it so I can always use it on projects.

    Thanks again,
    Leon

    http://wordpress.org/plugins/w3-total-cache/

  2. esmi
    Forum Moderator
    Posted 9 months ago #

  3. liton1980
    Member
    Posted 9 months ago #

    But i think you can't run W3Tc without increasing memory size. When you can do it,. why you don't? Another solution can be using a lighter caching plugin like WP super cache. And maybe you can run W3TC by not using all the features of it. Did you try it?

  4. Marc Queralt i Bassa
    Member
    Posted 9 months ago #

    Same situation found.
    As my PHP memory limit is set to 128MB the admin hangs showing a 64MB exhausted memory message.

  5. twoelevenjay
    Member
    Posted 9 months ago #

    Thanks esmi, however I did increase the PHP memory limit. This did not have an affect. I set the PHP memory limit to 64M the exhausted amount described in the PHP fatal error was 128M. I set the PHP memory limit to 96M and the exhausted amount described in the PHP fatal error remained at 128M. I set the PHP memory limit to 3000M and the exhausted amount described in the PHP fatal error still remained at 128M. The only setting with memory that is set to 128M is my post_max_size in the servers main php.ini file. This is very odd.

    Download Converter, I am the host I own the server that this website is installed on. We have actually hired out to have the server optimized for W3 Total Cache. I would not mind using less of it's options. The more I look into this the less I think W3 total cache has anything to do with it. On a fresh install with the default theme and no plugin W3 Total Cache runs fine with the PHP memory limit set to 32M.

    Marc Queralt i Bassa, It seems we have something in common. <span style="text-decoration:line-through;">This is the fact the the exhausted amount being displayed in the error is not reflecting our PHP memory limit. From what I understand this error usually is reflecting the PHP memory limit.</span>. Correction my problem is that the server is ignoring the memory limit set in wp-config.php. Do you have access to your main php.ini file? Can you view what your post_max_size is set to? You can use http://wordpress.org/plugins/wordpress-php-info/ to check your php settings.

    I know a common problem causer is when the post_max_size is set to a lower amount than the upload_max_filesize. It seems that default php.ini files come like this. This is not the case for me.

    I now feel like I have posted this question in the wrong forum.

    Does anyone know why my server would be ignoring the memory limit set in the wp-config.php file? Also does anyone know how to check the memory usage of each plug that I have installed. Maybe the theme too? would happen?

  6. Marc Queralt i Bassa
    Member
    Posted 9 months ago #

    I got the problem solved asking the hosting provider to set the php.ini config on a domain basis.

Reply

You must log in to post.

About this Plugin

About this Topic