WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Allowed memory size of 67108864 bytes exhausted (11 posts)

  1. yakos
    Member
    Posted 3 years ago #

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 80 bytes) in /home/agoradia/public_html/wp-includes/wp-db.php on line 958

    I am not sure what this means. I can see though that a lot of sites are getting similar errors. Is there a solution from WordPress somewhere ?

  2. Samuel B
    moderator
    Posted 3 years ago #

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    4. Talk to your host.
  3. yakos
    Member
    Posted 3 years ago #

    Thank you samboll for the suggestions.

    I have tried placing define('WP_MEMORY_LIMIT', '64M'); into wp-config.php - However this did not make any difference.

    Then I tried placing php_value memory_limit 64M into .htaccess but that actually made the whole site to go down. It could not be loaded and came up with "Internal Server Error". As soon as I removed the line from .htaccess it all went back to normal.

    I have also contacted my host, but I doubt if they will do anything about it. The error is re-produce-able.

    Hope that someone can provide another suggestion here.

  4. yakos
    Member
    Posted 3 years ago #

    Thank you everyone for your input
    This has been resolved once php.ini was changed and with the appropriate changes to .htaccess as well

  5. M Asif Rahman
    Member
    Posted 3 years ago #

    Solution to “Fatal error: Allowed memory size of 67108864/33554432 bytes exhausted”
    Here is Solutions:

    *** Here we consider 64M as good configuration. Depending on your need, server codition, how is your site, you could use 32M, 96M, 128M, 256M, 512M, 1024M, 2048M, 4096M. Make sure your server allow you to use that much dedicated memory.

  6. hkcharlie
    Member
    Posted 3 years ago #

    find the php.ini in the /public_html folder and edit the size of the limit and stipulated uper limit there.
    (worked for me)

  7. paulineconnelly
    Member
    Posted 3 years ago #

    I am having this error:

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 8391171 bytes) in /home/content/18/7016018/html/wp-includes/wp-db.php on line 785

    It sounds svery similar. I tried everything you said but it's not working.

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    ****This made no difference

    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    ****This made no difference

    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    ****This crashed the entire site

    THIS IS THE .HTACCESS CODE

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress
    php_value memory_limit 64M

    AM I DOING SOMETHING WRONG??

    4. Talk to your host.

    GoDaddy can't help.

    Can any one help???

  8. paulineconnelly
    Member
    Posted 3 years ago #

    Here is the error I get: ANY HELP WOULD BE SO APPRECIATED!!!!!

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache Server at http://www.mtnittanywinery.com Port 80

  9. wdfavour
    Member
    Posted 3 years ago #

    I got this error too. Fatal error: Allowed memory size of 67108864 bytes exhausted....
    Fortunately, it was just after I had installed the plugin 'Event-Registration'.
    So, I used my CPanel access and deleted the entire plugin from my Plugin Folder (public_html/wp-content/plugins/
    And my site came back up.

    So, you could check your plugins.

  10. wdfavour
    Member
    Posted 3 years ago #

    Well, after I went back in, I decided to deactivate some plugins (about 17). I re-installed 'Event-Registration' just to check. Everything worked just fine.
    So, it's a memory issue. Either increase it as suggested above, or delete some stuff.

  11. kndy71
    Member
    Posted 2 years ago #

    It's been years since I had this problem but the wp-config trick wasn't working anymore. So, I did the plug-in tests and sure enough, it was my caching program. I had to disable it and now everything works normally.

Topic Closed

This topic has been closed to new replies.

About this Topic