WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate (36 posts)

  1. ludovic116
    Member
    Posted 6 years ago #

    How can i fix it?
    I know on 2.5.1 i needed to increase the memdory, but i don't know how in 2.6. in the wp-config.php there no define to increase memory.
    What exactly do i have to do to fix, this please help me.
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home1/ebookrea/public_html/wp-includes/kses.php(900) : runtime-created function on line 1

  2. jarod.tm
    Member
    Posted 6 years ago #

    I've the same problem!
    How to solve?

    Please, help us!

  3. jarod.tm
    Member
    Posted 6 years ago #

    Ok, SOLVED:

    in wp-settings.php at line 13, increase from 32M to 64M!

    Bye.

  4. Moats
    Member
    Posted 5 years ago #

    jarod.tm that worked excellently for myself as well! Thanks for the solution!

  5. NasheedsNow.com
    Member
    Posted 5 years ago #

    thanks jarod.tm ur a legend! it worked for me :D

  6. markowe
    Member
    Posted 5 years ago #

    Thanks, that fixed it for me too, but I am just wondering if increasing the memory allocation is only postponing a bigger problem...?

  7. NasheedsNow.com
    Member
    Posted 5 years ago #

    hmm was wondering the same thing...

  8. cassembers
    Member
    Posted 5 years ago #

    Phew. I was trying to edit my php.ini memory and nothing was happening! I changed the wp-settings.php and it all works now. Thank you Jarod!

  9. Dlima
    Member
    Posted 5 years ago #

    I've this problem too, but not solved in my site.

    I increase from 32M to 64M in wp-settings.php and nothing hapened.

    Please, somebody help me!

    thanks

  10. webtvitaly
    Member
    Posted 5 years ago #

    I've increased the memory as well and still have the problem, any suggestions or solutions??? Thanks in advance!

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home6/webtvita/public_html/wp-includes/kses.php(1005) : runtime-created function on line 1

  11. rodfilardi
    Member
    Posted 5 years ago #

    Uow... it worked for me too :D
    You can see at http://www.rhodesign.com.br/blog/

  12. BernardBorealis
    Member
    Posted 5 years ago #

    Your host may not allow the 32M to 64M increase, or they may have a setting which overwrites the change you made to your wp-settings.php. This is something which can also be changed in the php.ini or the .htaccess, depending on the host. Contact them and find out if they allow you to increase that limit and find out which method ought to be used.

  13. mat8iou
    Member
    Posted 5 years ago #

    It makes more sense to add the line:
    define('WP_MEMORY_LIMIT', '64M');`
    to wp-config.php - wp-settings.php will be overwritten when you upgrade, but if the value is already defined in wp-config then it uses what is set there.

  14. breakingjist
    Member
    Posted 5 years ago #

    I set my limit to 64mb in the php.ini, wp-settings, and wp-config files but no luck. I am still getting the error. My hosting company (fatcow) allows up to 64mb. What can i do?

  15. cabridges
    Member
    Posted 5 years ago #

    Same problem, was missing 2 years worth of posts in export file. Changed the wp-settings after reading this, all is well. Whew! Thanks!

  16. ucsfstudent1
    Member
    Posted 5 years ago #

    I deactivated a few plugins and that seems to fix the problem.

  17. eftim
    Member
    Posted 5 years ago #

    yeah, it worked for me too :)

  18. galbaras
    Member
    Posted 5 years ago #

    Here's the full solution in the cleanest possible way:

    1. Create a file called php.ini in the root of your site (if you are using a hosted addon domain, this must be in the subdirectory of that site)
    2. In php.ini, enter a line that says
      memory_limit = 64MB
    3. In your site's .htaccess (being a WordPress blog, I'm assuming there is one), enter the following line
      SetEnv PHPRC /<unix path to the directory where php.ini is>/
      (keep the slashes)
    4. Edit wp-config.php and enter the following line
      define('WP_MEMORY_LIMIT', '64M');
    5. Upload the new files to the server

    Oh, and don't tell your hosting provider you've done this...

  19. galbaras
    Member
    Posted 5 years ago #

    Oops, I've checked my other sites after fixing the one with the problem and this solution killed them. However, I've removed the php.ini and the line in .htaccess and left only the line in wp-config.php and things are working OK.
    Arrrrrgh!

  20. step1
    Member
    Posted 5 years ago #

    great it worked

  21. lordbiodark
    Member
    Posted 5 years ago #

    through this problem long ago I was pounding.

  22. TruthMedia
    Member
    Posted 5 years ago #

    Is there some sort of memory leak in the WP query object? When attempting to run the upgrade from 2.7.1 to 2.8 I'm running out of memory.

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 10259034 bytes) in /var/www/obsficated/wp-includes/wp-db.php on line 501

    Yes, kids, thats 128 MB of memory used up by PHP. We do have over 6000 posts and over 3000 pages. Any suggestions here? (other than increasing the memory again?)

  23. AlpDmr
    Member
    Posted 5 years ago #

    It works, thank you so much...

  24. kumitey
    Member
    Posted 5 years ago #

    it works for me too. Thank you

    Kumitey

  25. hedicito
    Member
    Posted 5 years ago #

    Thanks a lot Jarod

  26. Kaskade
    Member
    Posted 5 years ago #

    jarod.tm you rock!!! Thank you so much!!!!

  27. hedonplay
    Member
    Posted 5 years ago #

    for those who have changed the php.ini memory_limit, but it still doesn't work, please think about to restart your web sever.

  28. Dirt2
    Member
    Posted 5 years ago #

    Just wanted to thank you Jarod for your help, helped me as well.

  29. cmguajardo
    Member
    Posted 5 years ago #

    Increasing memory to 64M in wp-settings.php worked for me - thanks!

  30. neriox
    Member
    Posted 5 years ago #

    Thanks Jarod, work totally for me!

Topic Closed

This topic has been closed to new replies.

About this Topic