WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate (4 posts)

  1. DELORES
    Member
    Posted 5 years ago #

    Getting error message on these pages on my site:
    # Add to Google
    # Chocolate Truffle Cakes
    # Dessert of the Month Club
    # Gift Baskets
    # Layer & Birthday Cakes
    # Top Sellers
    # DAVID’S COOKIES
    everything else is fine.

    Was told by Bluehost that this is a setting in the php.ini file it is call memory limit. New at this. Don't know anything about this or how to fix it. Can anyone help? My blog is http://www.doggy-waggin-tails.com
    Thanks

  2. whooami
    Member
    Posted 5 years ago #

    bluehost could have explained how to fix this for you.

    this is asked and answered here, a million times over,

    http://wordpress.org/search/Fatal+error%3A+Allowed+memory+size+of?forums=1

  3. MichaelH
    Member
    Posted 5 years ago #

    Methods for increasing the amount of memory a PHP script may consume

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '32M');

    4. Talk to your host.

  4. BernardBorealis
    Member
    Posted 5 years ago #

    As bit of additional information, the php.ini is not recursive. In order to make it work for whatever it is you're trying to do, you will likely want to do the following:
    Log into your cPanel, click on PHP Config. Click the option for single php.ini and save the settings. If you don't already have a php.ini in your root directory, you can also add the default php.ini right here in the PHP Config. It will be installed with a filename of "php.ini.default" so you will need to rename it to "php.ini" then find that file in the public_html directory and open it in your favorite editor and increase the memory_limit. You can also use the cPanel's File Manager to edit the file.

Topic Closed

This topic has been closed to new replies.

About this Topic