WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Allowed memory size of 33554432 bytes exhausted (24 posts)

  1. Pete
    Member
    Posted 5 years ago #

    What does this mean when I try to access my plugins in the admin?

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home/xyz/public_html/abc/tuv/wp-includes/kses.php(1005) : runtime-created function on line 1

  2. iridiax
    Member
    Posted 5 years ago #

  3. Pete
    Member
    Posted 5 years ago #

    yep thanks... i should of searched first sorry

  4. Saqib
    Member
    Posted 4 years ago #

    excuse me follows but I need to know is IF we increase the memory in wp-settings.php will it consume the PC on hosting service you see my hosting service has a pc usage limit. Thank You

  5. MichaelH
    Member
    Posted 4 years ago #

    saaqi - please ask your host HOW they will react to you increasing memory that PHP may consume.

    Note: I deleted the other exact question you asked in 4 other threads.

  6. clevercourtier
    Member
    Posted 4 years ago #

  7. Alexthewordpress
    Member
    Posted 4 years ago #

    go to your webhosting
    edit wp-settings.php [32M to 64M]

    Enjoy Your Rock !!

  8. ThomasTheGeek
    Member
    Posted 4 years ago #

    You don't actually need to increase it that much, so try 38M first and move it up slowly multiples of 2 till your error messages disappear, keeping it to a conservative amount may work better overall, especially if you are running more than one WP site on a shared server. Chances are 38M will do just fine, I had the same issue and it worked for me.

  9. sailo
    Member
    Posted 4 years ago #

    Hello guys,
    i was searching for that and its working now
    Alexthewordpress special thanks ;)
    thanks all :)

  10. Samuel B
    moderator
    Posted 4 years ago #

    edit wp-settings.php [32M to 64M]

    and if you do that your settings will be overwritten with every upgrade
    better to use one of the other solutions

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    4. Talk to your host.
  11. antistandard
    Member
    Posted 4 years ago #

    I changed my memory limit in wp-settings.php and then it gave me this error:

    Fatal error: Call to undefined function is_admin() in /sitepath/wp-includes/vars.php on line 16

    [Content moderated.]

  12. antistandard
    Member
    Posted 4 years ago #

    Lastly:

    I went into php.ini and changed the memory limit to 80M just to go overboard and hope I don't get errors in WordPress anymore which makes a 30 minute job take 30 days.

    I'll post up an update if it all goes well and hopefully others can benefit from my trial.

    With cross-browser incompatibility and wordpress errors and people still using IE6, I just don't know why we can't just make this all simple with more stable updates (don't release an update until it is 100% stable [moronic name calling deleted]), upgrade yor browser, use firefox, and get a mac.

    I mean it's not that difficult [moronic name calling deleted].

  13. WP Voyager
    Member
    Posted 4 years ago #

    Antistandard:

    Sir! Please regard your tone and choice of words! Really, If you want help within a community, ranting and raving unnecessarily about the object in question is NO way to get help!

    now, i looked up how to get rid of this error and people advise to re-install wordpress again (WHICH I JUST DID!!)

    Okay, I am not sure what exactly you looked up to try to troubleshoot your problem, but I will see what I can do to respond anyway. First of all, some people may be having problems like this because of a corrupt file, which would be a good reason to reinstall WordPress. But in your case, the error was caused by an edited file. This is probably due to some mismatched syntax, or something of the sort. In short, it probably could have been fixed by reverting to an earlier version of the file (if you made a backup before editing) or finding the problem with your edit.

    man, if I was a php developer I would make an awesome, stable Shopping Cart with great shipping options and then charge $5 to buy it.

    I find it necessary to remind you that the key word in your statement is IF. IF you want to go out and become a PHP dev and write a plugin, that's great! Really! I'm not being sarcastic. But if you want to become one and contribute to the community by producing a plugin (payed or not, as long as it works well), and then you wouldn't have to complain.

    WordPress is always bringing out flippn updates that make everyones adrenaline kick in just before you click the upgrade button because more times than not, you get a flippn error message where you have to start you life all over again.

    In computing, errors happen. MAKE BACKUPS. Computers are only as smart as the people directing them, and occasionally there will be slip-ups (whether it's you, someone at WP, someone at your host, etc.)

    i mean, what the **** is memory allocation anyway ??

    i mean, just use what you need in memory to get the ****ing job done Errorpress.

    Again, please moderate your tone. There are distinct limitations on purpose to prevent errors. If there is a plugin that uses to much memory due to a bug, or a hacker that does it on purpose, the memory limit is there as a safeguard. It also comes in handy when your host knows that there are limitations in place to keep their memory usage within good ranges.

  14. antistandard
    Member
    Posted 4 years ago #

    ok, that seemed to work, and it doesn't tax my system.

    Problem solved I guess.

  15. bajoah
    Member
    Posted 4 years ago #

    This Worked For Me- Settings then GD Press Tools: Settings
    Then Check Memory allocated by PHP: and I changed my to 120 instead of 64M. (php.ini: memory_limit [120M]) Help that helps someone just like
    samboll
    moderator Helped Me.

  16. sdriedger
    Member
    Posted 4 years ago #

    Thanks Everyone for this information. It resolved memory issues I was having on my blogs.

  17. klancast
    Member
    Posted 4 years ago #

    unfortunately none of the above has helped me, I have a wp blog with PHP Memory set to 64M, WP memory set to 64 and I am getting random fatal memory errors are approximately 20M (usually 20971520, sometimes 21233664).

    I had tried turning off the plug-ins I have installed and that did not help.

    I had changed my settings, had my host change the PHP limit to 64M but the errors persisted.

    I then went the brute force method, I deleted the entire wp installation (after a backup) then reinstalled a new clean copy (I had done several upgrades over the past year or so). I then added my content and SQL data back into the site and still get the errors.

    I am still getting the errors, tried cleaning up some of the entries that had multiple revisions to see if that helped.

    any other thoughts?

    thanks in advance.

  18. WP Voyager
    Member
    Posted 4 years ago #

    Sometimes excessive amounts of memory and resource usage result from your site being hacked. Now, this may not be the case. But, all the same, you might want to read the forum article My site was hacked.

    If it turns out to be a negative, you'll benefit from hardening WordPress anyway; it will protect against possible future attacks :-)

    I hope this information proves to be relevant,
    MindBlender 3D

  19. phroghollow
    Member
    Posted 4 years ago #

    I updated the memory allocated to PHP from 32Mb to 64Mb in my wp-settings.php and i`m now getting errors :
    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:771) in /home/danndel/public_html/wp-admin/async-upload.php on line 26

    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 17152 bytes) in /home/danndel/public_html/wp-admin/includes/image.php on line 162

    Now it seems i`ve completely rooted the whole install, it now has issues when trying to login :
    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-login.php on line 302

    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-login.php on line 314

    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-includes/pluggable.php on line 665

    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-includes/pluggable.php on line 666

    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-includes/pluggable.php on line 667

    Warning: Cannot modify header information - headers already sent by (output started at /home/danndel/public_html/wp-settings.php:765) in /home/danndel/public_html/wp-includes/pluggable.php on line 868

    HEEEELLLLP

  20. WP Voyager
    Member
    Posted 4 years ago #

    Ah, it sounds like you have a space (or other character) in your PHP file where it should not be.

    Codex Article: http://codex.wordpress.org/FAQ_Troubleshooting#How_do_I_solve_the_Headers_already_sent_warning_problem.3F

    If you still can't figure it out, please search the forums for information on the "Headers already sent" problem. There are several threads, because this seems to be a rather common problem.
    Example:http://wordpress.org/support/topic/279611?replies=9 (especially here)

  21. Nigel1
    Member
    Posted 4 years ago #

    Increased memory in php.ini file to 128M, and did same for wp-config.php and wp-settings.php files. Still getting memory error. Can't even access wp-admin.

    Will try to re-install WordPress, but if problem persists, I would sure appreciate some advice from those of you more experienced.

    Thanks!

  22. Have you tried increasing it in you .htaccess file? These are the recommended procedures for increasing memory:

    1. Try adding this line to your wp-config.php file:
    define('WP_MEMORY_LIMIT', '64M');
    
    2. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    3. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    4. Talk to your host.
  23. Nigel1
    Member
    Posted 4 years ago #

    Had already done all those things. Finally decided I must have had a corrupt database. So, installed my latest backup before the memory errors. Things are working again.

    Thanks for your help.

  24. Mariokluser
    Member
    Posted 4 years ago #

    Thank you guys!

    I changed the memory-limit in the php.ini from 32M to 38M and the problem is solved.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic