WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Allowed memory size of (6 posts)

  1. OSU_fighter
    Member
    Posted 5 years ago #

    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 30720 bytes) in (..)/wp-admin/includes/template.php on line 3236

    This is the error i get when trying to install wordpress. Been at it for a few hours now and can't get it to work. I dl'ed the files, edited the config file and uploaded the whole thing. I don't know what i'm doing wrong so i really hope that somebody can help me. I already tried to put a higher value in the memory_limit. THat also doesn't fix it.

    Please help me! Thanks in advance!

  2. ClaytonJames
    Member
    Posted 5 years ago #

    Take a read through these and see if anyone found a solution that might work for you as well.

  3. brmecham
    Member
    Posted 5 years ago #

    Here's what worked for me, similar to what others have recommended:

    add to wp-config.php:

    define('WP_MEMORY_LIMIT', '64M');

    I wish I knew what caused the problem initially... suddenly I couldn't access my backend (wp-admin)... and got the error about allowed memory size exhausted... I disabled some plugins and was able to access the backend. I then renabled plugins except for any that I could live without. However, I was still seeing the message in certain places like in the Dashboard under "wordpress development blog" and "Other WordPress News"... instead of showing the feed data it was just showing the memory error within those boxes. This fix made those errors go away.

    Now I just wonder if there's a way to optimize what I am using to not go over the 32M default limit? Or is there some other error that it's causing it to go over the 32M limit and what I've done is simply applying a band-aid by raising the limit to 64M?

  4. nonbreakingspace
    Member
    Posted 5 years ago #

    @brmecham thanks for your post,

    add to wp-config.php:
    
    define('WP_MEMORY_LIMIT', '64M');

    fixed it for me :)

  5. Samuel B
    moderator
    Posted 5 years ago #

    php memory is no big deal - you could set it at 96M and it doesn't cause a strain on the server or anything
    many things can cause excessive php memory usage
    too many plugins
    server not configured correctly
    too many queries in the permalink settings, etc.

    that it's working is the good news

  6. joshofsorts
    Member
    Posted 4 years ago #

    Try turning off some plugins and then upgrade automatically. After it has upgraded WordPress, then turn the plugins back on.

Topic Closed

This topic has been closed to new replies.

About this Topic