WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Allowed memory size of 134217728 bytes exhausted (6 posts)

  1. Dianna Jacobsen
    Member
    Posted 2 years ago #

    getting this error on website:
    http://frenchgardenrestaurant.com/

    Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 20 bytes) in /nfs/www/WWW_pages/sorrel/frenchgardenrestaurant.com/wp-content/themes/genesis/lib/widgets/enews-widget.php on line 39

    Client was just editing pages yesterday and claims they did not add any plugins or upgrade anything.

    Does anyone have any idea as to what the problem is? Thanks so much in advance!

  2. Using FTP you can try increasing the memory for PHP and WordPress in several different ways:

    1) You can edit the memory_limit line in your php.ini (if you have access to that file) to increase memory to 64M:

    memory_limit = 64M;

    2) If you can't get to the php.ini file, add this line at the top of your .htaccess file:

    php_value memory_limit 64M

    If that doesn't work or throws a "500 Internal Server Error", delete the line from .htaccess.

    3) Try adding the line below near the top of your wp-config.php file, a few lines of white space below the opening <?php

    define('WP_MEMORY_LIMIT', '64M');

    If none of those work, your host probably doesn't allow memory allocation overrides. You're stuck with what they give.

    You can run phpinfo to see what kind of memory allocation you already have. Make a plain text file and call it phpinfo.php and put just this line in it:

    <?php phpinfo(); ?>

    then put the file in the root of your server, and then go to that file with your web browser. You'l see all the php info you need; scroll down for memory settings. If you get an error, that means your web hosting company won't allow phpinfo to run for security reasons.

  3. Dianna Jacobsen
    Member
    Posted 2 years ago #

    Thank you for quick response. I don't have access to php.ini file. I tried step 2 (editing .htaccess) no effect, tried step 3 (editing wp-config.php) no effect.

    I created the phpinfo.php file and got all of the info:
    http://frenchgardenrestaurant.com/phpinfo.php

    looks like memory limit is set to 128m

    Hmmm... any other thoughts on what the issue could be?

    Thanks again!

  4. Must be the theme. Use FTP to rename the genesis theme folder to disable it and see if another theme works. See Filezilla and FTP Clients « WordPress Codex

  5. Dianna Jacobsen
    Member
    Posted 2 years ago #

    Yes, disabled the theme and it worked. Upgraded everything reinstalled the theme, and everything works now. Thanks so much for your help!

  6. Please post support questions for Genesis at http://studiopress.com/support/

Topic Closed

This topic has been closed to new replies.

About this Topic