WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error: Allowed memory size exhausted (15 posts)

  1. vitalichka
    Member
    Posted 3 years ago #

    So I have been getting the Fatal error: Allowed memory size exhausted error but everything worked.
    I tried to fix it by increasing memory allocation to 64 MB by following directions here Link 1

    That did nothing.

    So I moved to the next level by following
    Link 2

    This did nothing.

    What else can I do?

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/westmins/public_html/wp-includes/class-simplepie.php on line 5427

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/westmins/public_html/wp-includes/class-simplepie.php on line 5427

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 1966080 bytes) in /home/westmins/public_html/wp-includes/class-simplepie.php on line 5427

    Also, now my auto updates don't work. This was an issue before upgrading to WP 3.0

    Hope someone could help me out.
    And I have full access to host settings in CPanel, doesn't seem like settings are being overwritten by the host.

  2. James
    Happiness Engineer
    Posted 3 years ago #

    First, try installing the Memory Bump plugin.

    If that doesn't work, here are four ways to increase PHP's memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    
    4. Talk to your host.
  3. vitalichka
    Member
    Posted 3 years ago #

    I've done the first three. Nothing.
    Speaking to my host is useless.

    I have done php.ini by creating the file.
    I have also done .htaccess
    I have also added the line to wp-config

    Did nothing.

    Also, right now what I have going in and out is
    "Briefly unavailable for scheduled maintenance. Check back in a minute."

    Anything else I can do?

  4. James
    Happiness Engineer
    Posted 3 years ago #

    If speaking to your host is useless, which it should never be, you might want to consider the unlisted #5.

    5. Switch to another hosting provider.

  5. vitalichka
    Member
    Posted 3 years ago #

    Well, what I mean is that I have complete access ti all things hosting. All control to CPanel, anything they can do, so can I.
    What do I need to do, or better yet, what does the host need to do?

  6. vitalichka
    Member
    Posted 3 years ago #

    Alright, did everything one more time, still same errors and any time I run plugin updates I get the maintenance error which locks me out for a few minutes at a time.

  7. chrisebbeck
    Member
    Posted 3 years ago #

    Yeah i have tried the same steps as you and I get the errors all over my dashboard.
    I am on 2.9.2

  8. vitalichka
    Member
    Posted 3 years ago #

    chrisebbeck, I was getting these in 2.9.2 and still get them after following three different posts, multiple steps, multiple times. I am considering reinstalling the entire blog. The issue with this as I see it is that I really don't want to be doing this all of the time.

    Right now the blog works, not properly but it works. And I just don't want to have to reinstall and reconfigure everything every time something goes bad.

  9. James
    Happiness Engineer
    Posted 3 years ago #

    Well, what I mean is that I have complete access ti all things hosting. All control to CPanel, anything they can do, so can I.

    That's not true. cPanel is just an interface designed for you to have limited control over your small patch of hosting space. Your hosting provider can do much more. Ask them to bump PHP's memory allocation.

  10. vitalichka
    Member
    Posted 3 years ago #

    Thanks for the tip, I will be doing so very soon. However if you'd refer to my other post here it'd be great.

    After having a bunch of issues I could not resolve I decided to wipe the slate clean and reinstall everything. After doing so, I still don't have access to permalinks, it's just a blank gray screen even without any plugins running. The post may be better at explaining the issue and if there is anything you could help me out with, that would be absolutely great.

    Thanks everyone.

    Post link

  11. vitalichka
    Member
    Posted 3 years ago #

    Okay so as an update I wanted to let you guys know that when I loaded an old db backup using WP-DBManager

    The errors came back.
    The errors were not there when I reinstalled WP fresh. Once I reinstalled the old db file it all came back.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 491520 bytes) in /home/westmins/public_html/wp-includes/class-simplepie.php on line 4187

    However, when I reinstalled a fresh copy of WP 3.0 I still could not access permalinks. You can see more about this in this post.

  12. chrisebbeck
    Member
    Posted 3 years ago #

    i am still having problems with this.
    I have contacted my host and they told me to do the following:

    "Please create php.ini file and then put memory_limit = whatever memory you want to set. Once it's done upload it to the directory where you are running that php script."

    I don't know what needs to be in the php.ini file or where to place it?

  13. vitalichka
    Member
    Posted 3 years ago #

    chrisebbeck, create a php.ini file and insert this line into it.

    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    However I want you to know that I did this and it made no difference for me. However we need to keep in mind that this may work for you because you likely have a different host from me.

    Give it a try and also take a look at this link and pay attention to what MichaelH said towards the middle of the post. He gives you three options and you can try them until you find one that takes care of this for you.

    You can also try using the Memory Bump Plugin as it is recommended by the WordPress community, it was created for this purpose, I believe it does what you'd be doing manually but give it a try if you want.

    Good luck.

    BTW, I am still having the same problem. When I reinstall a fresh copy of WP 3.0 all is good with the memory usage but as soon as I load a DB back up it all goes back to the error. So I know this isn't an issue with the host.

  14. chrisebbeck
    Member
    Posted 3 years ago #

    Ok I fixed this and it was very simple.

    I tried all of the following and none worked:
    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

    I have no access to my php.ini file. So I created my own php.ini file with the following in it and added to my wp-admin folder.

    <? phpinfo(); ?>
    memory_limit = 128M

    and it is all fixed!
    So simple, I have been trying to work this out all week.

  15. tutorialsbucket
    Member
    Posted 3 years ago #

    thank you chrisebbeck

    <? phpinfo(); ?>
    memory_limit = 128M

Topic Closed

This topic has been closed to new replies.

About this Topic