WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Fatal error: Allowed memory size exhausted (9 posts)

  1. celsydney
    Member
    Posted 6 months ago #

    I have been away on holiday (without access to my site) for a few weeks and upon my return I noticed that I can't access my website and receive the following fatal error:

    Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 1048576 bytes) in /****.com/public_html/wordpress/wp-includes/option.php on line 250

    After some searching I found out that it's the nextgen gallery causing this as with the plugin deactivated everything works fine.

    I managed to do the latest nextgen gallery update without any success.

    Is there a solution for this?

    Thanks

    http://wordpress.org/plugins/nextgen-gallery/

  2. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @cetsydney - You may need to have your PHP Memory Limit increased to at least 128MB but preferably 256MB. Perhaps your web host can help you sort that server environment issue out?

    - Cais.

  3. celsydney
    Member
    Posted 5 months ago #

    This is not really resolved unfortunately. Increasing the memory limit is not an option.

    I don't think NGG should be such a heavy plugin that it creates this memory error =/

    I'm not sure what has changed lately that is causing this problem as I have never had any issues like this until the last two weeks.

    I hope someone can have a look at the backend of NGG to see what is causing NGG to eat up all the memory as a plugin like this should not be this heavy.

  4. tizz
    Member
    Posted 5 months ago #

    celsydney, you have a low PHP memory limit, 96 MB.
    While a few years ago could be enough now isn't anymore, and other plugins may not work, not only Nextgen.
    If I were you I'd insist with the provider, telling them that other providers offer at least 128 MB on shared servers at the same or lower price (it's the truth, I don't know how much you spend but you can do a search and compare - but if you spend very little otherwise you can't complain), and without the increase you're forced to change provider, which in the end is what you should do, or change your plan with the same.
    In past I've had your same problem with another plugin, my host told me he couldn't increase it because I was on a shared server. I told him that I would have to switch to another provider to solve the problem and they raised it right away.
    You can give a try, because I don't think that what you're asking for is possible.
    I'd love too, but I don't think it's so easy.

  5. eevan79
    Member
    Posted 5 months ago #

    Increase the memory limit is not an option.

    Keep in mind that a huge memory limit is a poor substitute for good coding. A poorly written script may inefficiently squander memory which can cause severe problems for frequently executed scripts.

    Also, there is a possibility to suspend your account.

  6. Maurice_Ormon
    Member
    Posted 5 months ago #

    I'm having the same issue with the recent upgrade to Nextgen. Suggesting we increase memory size is all well and good, but the problem did not exist before this upgrade to Nextgen. I've disabled the sidebar widget that displays random images, but the main blog pukes on a "singlepic" and crashes the whole blog. (www.mauriceo.com).

    I'd have to say it is a problem with NExtgen.

    However, I certainly will try to increase the memory limit... can you give a bit more detail on how to accomplish this?

  7. tizz
    Member
    Posted 5 months ago #

  8. Maurice_Ormon
    Member
    Posted 5 months ago #

    I edited my php.ini file to include the following

    memory_limit = 256M

    It let one additional post display (albeit not properly) then got the same out of memory allocation.

  9. Maurice_Ormon
    Member
    Posted 5 months ago #

    tizz: I edited the file and changed the limit to 256 and it worked. Thanks for the reply.

Reply

You must log in to post.

About this Plugin

About this Topic