WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error - allowed memory size exhausted (13 posts)

  1. Deborah Jackson
    Member
    Posted 2 years ago #

    I have a very simple little site hosted at http://www.djpsych.com.au.

    Just now I tried to activate the Jetpack plugin and authorised WordPress.com to link to my site. As a result I received the followed error message and now can't access the admin area of my site - keep getting this same error message.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home2/djpsychc/public_html/wp-admin/includes/deprecated.php on line 21

    What has happened? I'm a complete novice at this stuff and am pretty stressed that I now can't use a site I spent weeks setting up.

    Some help here would be much appreciated.

    Thanks,

    Deborah

  2. Deborah Jackson
    Member
    Posted 2 years ago #

    Oh - the site was created in WordPress.org

  3. Deborah Jackson
    Member
    Posted 2 years ago #

    I don't really even understand what memory means here - is it working memory like RAM or storage memory?

    It seems hard to believe I could have exhausted a standard memory allocation with a dozen pages on a brochure site.

  4. Deborah Jackson
    Member
    Posted 2 years ago #

    OK - I just paid some money to an online tech support person and he gave me the simple and helpful advice to call my hosting provider and ask them to increase my php memory limit. They did this straight away and I'm back in business.

    Maybe this note will help someone like me down the track who is not so tech savvy.

  5. That's a very common problem with inexpensive hosts; sorry you spent money, but if you searched the forums you would have found the answer.

    Which is:

    Using FTP you can try increasing the memory for PHP and WordPress several different ways:

    1) You can edit the memory_limit line in your php.ini (if you have access to that file) to 64M:

    memory_limit = 64M;

    2) If you can't get to the php.ini file, add this line at the top of your .htaccess file:

    php_value memory_limit 64M

    3) If that doesn't work or throws a "500 Internal Server Error", delete the line from .htaccess.

    Then try adding the line below near the top of your wp-config.php file, right after the opening <?php

    define('WP_MEMORY_LIMIT', '64M');

    If none of those work, your host probably doesn't allow memory allocation overrides. You're stuck with what they give.

    You can run phpinfo to see what kind of memory allocation you already have. Make a plain text file and call it phpinfo.php and put just this line in it:

    <?php phpinfo(); ?>

    then put the file in the root of your server, and then go to that file with your web browser. You'l see all the php info you need; scroll down for memory settings. If you get an error, that means your web hosting company won't allow phpinfo to run for security reasons.

  6. Deborah Jackson
    Member
    Posted 2 years ago #

    Hi Songdogtech,

    Thanks for this info. I did search the forums and read a lot of technical info that I didn't understand, so was grateful for a simple, human way to solve the problem. I'm not a programmer or designer.

    Although, it's just clicked with me I can go into the File Manager at Crazy Domains and find the code and make the changes you suggest. I have learnt something, thank-you, I will save this info for future reference.

    BTW - are there any hosting providers you recommend?

    Thanks,

    Deborah

  7. manndtp
    Member
    Posted 2 years ago #

    You could always try contacting your web host and see if they can increase the php memory limit. Some will and some will not. Working with the host I use, I have been able to get the memory limit increased.

    Edit: Next time I will read all posts before posting. Glad that your web host increased the limit for you.

    As for exhausting the memory, yes it is easy to do so with certain plugins. Some are quite memory intensive. The memory usage is the total amount of RAM needed to render the entire page for the end user. This includes all the plugins you might have installed and activated on your site.

  8. Deborah Jackson
    Member
    Posted 2 years ago #

    Hi Manndtp,

    Ahhh .. thanks for this insight into what the memory issue is about - makes more sense to me now!

    Cheers,

    Deborah

  9. tomspiglanin
    Member
    Posted 1 year ago #

    Having the SAME problem. Have NEVER had a problem with my host and have over a decade experience programming websites. 7 years with this host. Is this really a hosting issue?

  10. manndtp
    Member
    Posted 1 year ago #

    The memory issues are due to the increased amount of memory WordPress and plugins take. It is the way the server is setup and the allotted memory to each site.

  11. sarachristen
    Member
    Posted 1 year ago #

    I am having the same problem with the Jetpack update. I tried calling my host to get my php memory increased and their only answer was to sell me time with a specialist. I'm happy to take a chance and make the edits myself, if I only knew how to access the php.ini file... or deactivate the plugins! any help for a non-programmer like me would be appreciated... i just don't even know where to begin.

  12. sarachristen
    Member
    Posted 1 year ago #

    is it possible to un-install all plugins?

  13. sarachristen
    Member
    Posted 1 year ago #

    hooray! i found the solution here: http://codex.wordpress.org/FAQ_Troubleshooting

    (the only access I have is phpMyAdmin)

    How to deactivate all plugins when not able to access the administrative menus?

    Sometimes it may be necessary to deactivate all plugins, but you can't access the administrative menus to do so. One of two methods are available to deactivate all plugins.

    Use phpMyAdmin to deactivate all plugins.

    In the table wp_options, under the option_name column (field) find the active_plugins row
    Change the option_value field to: a:0:{}

    Or reset your plugins folder via FTP or the file manager provided in your host's control panel.

    Via FTP or your host's file manager, navigate to the wp-contents folder (directory)
    Via FTP or your host's file manager, rename the folder "plugins" to "plugins.hold"
    Login to your WordPress administration menus (/wp-admin)
    Via FTP or your host's file manager, rename "plugins.hold" back to "plugins"

Topic Closed

This topic has been closed to new replies.

About this Topic