WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Allowed memory size??? (13 posts)

  1. webbert
    Member
    Posted 5 years ago #

    Im trying to install some plug ins and get this error message

    "
    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in"

    What is wrong? How can i fix this

    Now, i cant get in to my plug in section.. i only see this error message

  2. MichaelH
    Member
    Posted 5 years ago #

    Methods for increasing the amount of memory a PHP script may consume

    0. If you have access to your install and are running a version of WordPress earlier than 3.0, try the plugin
    http://wordpress.org/extend/plugins/memory-bump/ as this is the easiest way to increase your RAM for WordPress. [Mod note - Link Added 2010-06-21]

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M. If your line shows 64M try 128M
    memory_limit = 64M ; Maximum amount of memory a script may consume (32MB)

    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');

    4. Talk to your host.

  3. brmecham
    Member
    Posted 5 years ago #

    Here's what worked for me, similar to what others have recommended:

    add to wp-config.php:

    define('WP_MEMORY_LIMIT', '64M');

    I wish I knew what caused the problem initially... suddenly I couldn't access my backend (wp-admin)... and got the error about allowed memory size exhausted... I disabled some plugins and was able to access the backend. I then renabled plugins except for any that I could live without. However, I was still seeing the message in certain places like in the Dashboard under "wordpress development blog" and "Other WordPress News"... instead of showing the feed data it was just showing the memory error within those boxes. This fix made those errors go away.

    Now I just wonder if there's a way to optimize what I am using to not go over the 32M default limit? Or is there some other error that it's causing it to go over the 32M limit and what I've done is simply applying a band-aid by raising the limit to 64M?

  4. Shane G
    Member
    Posted 5 years ago #

    Hi,

    1) Either rename/remove Plugins folder via FTP or disables all the Plugins from database.

    2. If you have an access of PHP.ini file of the account/server then change the line in PHP.ini where line shows 32M to 256M:
    memory_limit = 256M; Maximum amount of memory a script may consume (64MB)

    3. If you do not have access of PHP.ini file then add this to an .htaccess file of your domain:
    php_value memory_limit 256M
    4. Try to add this line to your wp-config.php file to increase allocated memory to PHP:
    define(’WP_MEMORY_LIMIT’, ‘256M’);

    If all this option can not resolve the issue then you need to contact your hosting service provider to resolve this issue.

    Thanks,

    Shane G.

  5. JudithStep
    Member
    Posted 4 years ago #

    Wow. I just saw this response. You guys so ROCK! Thankfully my host fixed it, but I now understand what happened. Thank you!

    Judith

  6. actionflickchick
    Member
    Posted 4 years ago #

    Where do I find the php.ini file?

  7. esmi
    Forum Moderator
    Posted 4 years ago #

    Ask your hosts.

  8. cibertek
    Member
    Posted 4 years ago #

    Disabling all the plugins first was what worked for me. Thanks guys.

  9. byandreasdotcom
    Member
    Posted 4 years ago #

    Thanks Cibertek! That's the trick! I changed the memory limit over and over again... until I deactivated all the plugins and tried to upgrade again :) Done!

  10. MsBarbara
    Member
    Posted 4 years ago #

    My Host told me I cannot do this. I have 64m and that's all I get unless i upgrade to VPS or dedicated server. did I ask a "dumb" question?

  11. frih
    Member
    Posted 4 years ago #

    Barbara thats true, Many shared host offers such limit. To get more, you need a VPS.

  12. MsBarbara
    Member
    Posted 4 years ago #

    Thanks. This is certainly an ongoing learning process. Will this be terribly limiting? should I have a VPS?

  13. dparisut
    Member
    Posted 4 years ago #

    I just ran into this on my wife's blog. It took changing memory settings to 128M to have the error go away.
    I had to adjust both the php.ini file and the wp-settings.php file. Until I adjusted the wp-settings to 128M we continued to have the error. So if changing from 32M to 64M does not work I would recommend bumping up the memory settings like SHane said above.

    Now of course what makes little sense to me is that I downloaded her dB and site to a dev server that is set to 32M and had absolutely no memory errors. My dev server is only running about 50 sites and I'm wondering how much of this problem is a result of her blog being up on a server with nearly a 1000 sites. Hmmm

Topic Closed

This topic has been closed to new replies.

About this Topic