WordPress.org

Ready to get started?Download WordPress

Forums

Fatal error: Allowed memory size... (12 posts)

  1. mjnbrn
    Member
    Posted 5 years ago #

    Hey,
    I am trying to update my about page, but every time I hit Update, it goes to this :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 122880 bytes) in /home2/mjnbrnne/public_html/wp-content/plugins/google-sitemap-generator/sitemap-core.php on line 1741

    The line number changes sometimes, like the time before it was 2063... samefile though. any help is greatly appreciated.

    I installed Wp-Super Cache a few days ago, and this didn't happend before that.

  2. mjnbrn
    Member
    Posted 5 years ago #

    Now I'm getting this error when i try to edit my plugins :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 7680 bytes) in /home2/mjnbrnne/public_html/wp-includes/kses.php(1006) : runtime-created function on line 1

  3. mjnbrn
    Member
    Posted 5 years ago #

    Alright, I got it worked out. The problem was in some funky php.ini settings. Yay!

  4. webtvitaly
    Member
    Posted 5 years ago #

    Having the same problem with my site... mind posting the solution?

  5. massacre
    Member
    Posted 5 years ago #

    Hello! Since few days I got the same error. I am not sure, but it happens after exact number of plugins - if I delete one of the already installed and upload new one - in 99% everything is fine. My memory_limit is set to 32MB. Really, it would be nice if mjnbrn tell us how he fixed the problem. Thanks in advance!

  6. mariostella
    Member
    Posted 5 years ago #

    I solved mine getting more RAM from my provider (now I have 512 MB). The RAM was exceeded a total of 1 million and a half times, so it was time to upgrade. Are you sure this is not your case?

  7. EgOiStE
    Member
    Posted 5 years ago #

    it is just silly to ask the community to help you, then solve your problem, and then not say what your fix was.
    I had this same problem. I deactivated all plugins and increased the memory_limit variable under Resource Limits in my php.ini and it worked without a hitch to upgrade my WordPress.

  8. bh_WP_fan
    Member
    Posted 5 years ago #

    Ways to increase your memory_limit. Note that there are hundreds of posts all over these forums for fixes to this problem. A little time browsing works wonders.
    1. Increase the memory limit setting in php.ini (e.g. memory_limit = 64M ;). Many hosts may not allow this.
    2. Increase the memory limit via .htaccess (e.g. php_value memory_limit 64M). Many hosts may not allow this.
    3. Increase the memory limit via wp-config.php (e.g. define('WP_MEMORY_LIMIT', '64MB');)

  9. mcbalz
    Member
    Posted 5 years ago #

    bh_WP_fan... none of the solutions you have mentioned work for me.

    The wp_config.php fix seems to do nothing.
    (Also tried the parallel suggestion to change the variable in the wp_spettings.php file).

    Changing .htaccess results in a server 500 error.

    I can't find any php.ini file.

    I don't think this is a true memory issue.

    I have two blogs on my domain. Both are having the same issue.

    Both were working fine yesterday... AND I DID NOTHING TO CHANGE THEM since then.

    Both blogs are using MySQL databases that are each well under 2 MB. Mind you, these are small blogs. There shouldn't be a problem with memory allocation.

  10. bh_WP_fan
    Member
    Posted 5 years ago #

    @mcbalz: You are getting the Fatal error: Allowed memory size of [#of] bytes exhausted (tried to allocate [#of] bytes) ... etc., error, right? The php.ini file does not always exist on its own, sometimes you have to create it and add the lines to it yourself, or sometimes your host can create it for you. If this still won't work, contact your host and see what their memory_limit is set at and see if they can increase it for you.

  11. brmecham
    Member
    Posted 5 years ago #

    Here's what worked for me, similar to step #3 from bh_wp_fan, except with 64M (not 64MB)...

    add to wp-config.php:
    define('WP_MEMORY_LIMIT', '64M');

    I wish I knew what caused the problem initially... suddenly I couldn't access my backend (wp-admin)... and got the error about allowed memory size exhausted... I disabled some plugins and was able to access the backend. I then renabled plugins except for any that I could live without. However, I was still seeing the message in certain places like in the Dashboard under "wordpress development blog" and "Other WordPress News"... instead of showing the feed data it was just showing the memory error within those boxes. This fix made those errors go away.

    Now I just wonder if there's a way to optimize what I am using to not go over the 32M default limit? Or is there some other error that it's causing it to go over the 32M limit and what I've done is simply applying a band-aid by raising the limit to 64M?

  12. jtribue@cox.net
    Member
    Posted 4 years ago #

    IT WORKED! Thank you so much. I'm not where near an expert, but I was able to make the changes thru Dreamweaver and save to my server and the problem is fixed. Thanks soooo very much.

Topic Closed

This topic has been closed to new replies.

About this Topic