WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Fatal Error: Allowed memory size (9 posts)

  1. Shmeric
    Member
    Posted 2 years ago #

    I just attempted to upgrade my wordpress to 3.2.1 and got this error after fixing tons of other problems:

    Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 77824 bytes) in /srv/disk5/759703/www/trombonepedagogy.com/wp-admin/includes/dashboard.php on line 695

    I have no idea how to fix this and am not experienced with code or anything of the sort. Any help would be greatly appreciated! Thanks!

  2. RichardWPG
    Member
    Posted 2 years ago #

    You may ask your hosting provided to increase the size of the default memory and it should be able to fix it.

  3. Ryan Street
    Member
    Posted 2 years ago #

    You can also try this:

    Create a file called php.ini

    open this file in a text editor

    Add the following line:

    memory_limit = "256M"

    Save the file.

    Upload to your server in the same folder as your WordPress.

  4. TCBarrett
    Member
    Posted 2 years ago #

  5. Webfaden
    Member
    Posted 2 years ago #

    Sometimes there's also the simple option to increase your memory limit yourself if you log in to your hosting account and view your server options. But sure enough whether or not you can choose those values yourself depends on your host.

  6. Shmeric
    Member
    Posted 2 years ago #

    Thanks for all the help. I tried all the suggestions from you all and none worked. I have decided to just switch back to a previous version of WordPress and that is working. I use a free hosting site so I do not have the ability to change a lot of options. Thanks again!

  7. esears
    Member
    Posted 2 years ago #

    I'm dealing with this fatal error: allocated memory issue too with my search feature.

    PHP Fatal error: Allowed memory size of 524288000 bytes exhausted (tried to allocate 523800 bytes) in /var/www/html/wp-includes/query.php on line 2913

    I've set the size all the way up to 500MB in the PHP.ini file, .htaccess and WP-Config.php, and that still hasn't fixed it. I've also created a new PHP.ini file in the WP-admin folder with the following memory_limit = 500M and that didn't work.

    Any help someone can offer is greatly appreciated.

  8. esears
    Member
    Posted 2 years ago #

    Okay. It turns out I had too many pulgins activated. I turned off ones I wasn't using and now the search works.

  9. freifer
    Member
    Posted 1 year ago #

    The only solution I found works for this annoying problem is is what 'ryanstreet" suggested above.

    1-Open new text editor file ( notepad )
    2-Add the following line:
    memory_limit = "256M"

    3- In notepad, click on file > Save as > in the file name type: php.ini then click Save.

    4- upload php.ini to your WordPress root folder
    5- upload the same php.ini to wp-admin folder as well.

    Done.

Topic Closed

This topic has been closed to new replies.

About this Topic