WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] Fatal error after update WP 3.5 (11 posts)

  1. bschmidttraub
    Member
    Posted 1 year ago #

    Hi,
    here the message I get:
    Fatal error: Call to a member function getAllCaps() on a non-object in .../wp-content/plugins/advanced-access-manager/mvb_wp_access.php on line 383

    Bertram

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. Márcio Soares
    Member
    Posted 1 year ago #

    I have the same error... somebody know something about?

  3. Hassan
    Member
    Posted 1 year ago #

    I did not update to WordPress 3.5 yet because I knew some plugins would break. This plugin says (Compatible up to: 3.4.2) on its info.
    I advise you to roll back if you have a recent backup. Also, in the future try to test ALL your plugins with the latest WP version on a test environment first BEFORE upgrading the real website.

  4. tairak
    Member
    Posted 1 year ago #

    I am having a similar issue. Breaks my whole site.

  5. morandan
    Member
    Posted 1 year ago #

    My experience is if Advanced Access Manager was already installed and active before upgrading WordPress to 3.5, it still works smoothly. But on sites that I tried to install it on after upgrading to 3.5, when I go to the plugin page, it is a blank white page.

  6. alexnl
    Member
    Posted 1 year ago #

    This may be the reason why my install is not working. I upgraded to 3.5 a couple of weeks ago, but only installed access manager today. I get the same blank white screen morandan is experiencing. I also get this error when clicking on AWM Group from the sidebar:

    Fatal error: Fatal error: Class 'SoapClient' not found in /home/pinosal/public_html/wp-content/plugins/advanced-access-manager/mvb_wp_access.php on line 147

    And when clicking Access Manager I get a popup: Error: cannot call methods on dialog prior to initialization; attempted to call method 'destroy'

  7. Hassan
    Member
    Posted 1 year ago #

    The weird thing is, this plugin received an update on Dec, 25... that's after the release of WordPress 3.5, yet, it still says compatible up to 3.4.2

    and the bug(s) are still here...
    and the dev(s) are still (not?) here...

  8. bschmidttraub
    Member
    Posted 1 year ago #

    Nope,
    no response from the developer! Seems that this plugin isn't maintained any more.
    I've switched to "user role editor"
    The plugin works with wp 3.5.

  9. TedChapin
    Member
    Posted 1 year ago #

    Serious bummer. I have a dependency that required a really complex setup. Trying to bring members of a not for profit org online. I am disappointed there is no interaction from developer. If I have to roll back WP version and therefore several other plugins and lose the bug fixes in those or otherwise switch to another user role editor and reconfigure all of my access rules, it will suck.

  10. WP AAM
    Member
    Plugin Author

    Posted 1 year ago #

    Hi guys,
    My apology for ignoring you. There are times when priorities are changing in our life.
    Now I'm coming back to AAM support. Well slowly, but it'll get better.

    So I checked that error. I'm not sure that you are using the latest version of AAM.
    You have to upgrade to the latest one.

    alexnl. You see this error because you do not have SOAP support. This page will be deleted in next release. And this error does not affect any other side of the system. Also Javascript error very fixed.

    And one more thing. It is a good practice to make database backup before you install any WP plugin. This is just in case something get broken.

    Thanks guys for your feedback.
    Vasyl

  11. Hassan
    Member
    Posted 1 year ago #

    Thank you Vasyl. It is great to hear from you again. Looking forward for future development and fixes for this brilliant plugin of yours.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic