WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Fatal Error After Update (10 posts)

  1. Andrea Reed
    Member
    Posted 8 months ago #

    Hi, I backedup my site, updated to WP 3.8 then updated Customizr. I am using a child theme which is activated. After updating to WP 3.8, the site was still good. After updating the theme, I received this message:

    Fatal error: Cannot redeclare class TC_slider in /homepages/11/d364271349/htdocs/synergy/wp-content/themes/customizr/parts/class-content-slider.php on line 15

    Please help.

    Thanks,
    Andrea

  2. Andrea Reed
    Member
    Posted 8 months ago #

    Reinstalled backup. Site is still down with fatal error.

  3. ElectricFeet
    Member
    Posted 8 months ago #

    What happens if you activate Customizr, rather than the child theme?

    If that gets the site back up, tell us what's in your child theme.

  4. Andrea Reed
    Member
    Posted 8 months ago #

    It's looking like the theme is not compatible with WP 3.8...

  5. Andrew
    Forum Moderator
    Posted 8 months ago #

    The Child Theme you mean?

  6. Andrea Reed
    Member
    Posted 8 months ago #

    Not sure. Right now that's unlikely that the issue is with the Child Theme as there are minimal changes from the original and it's mainly basic CSS. Still working on restoring...

  7. ElectricFeet
    Member
    Posted 8 months ago #

    Customizr 3.1.5 is fine with WP 3.8 -- loads of us are using it with no problems. It has to be the child theme or your installation.

    The error is telling you that you are trying to load the same function twice. So either you have something in your child theme that is doing this, or you have an extra copy of one of the theme files in the theme folders.

    The first step is to see if Customizr works on its own. If it doesn't then there is something corrupted in your installation of Customizr. Delete it from the WordPress dashboard and reinstall it from the dashboard.

    Once you have Customizr (with no child) working then we can try to figure out what's wrong with the child.

  8. Andrea Reed
    Member
    Posted 8 months ago #

    Awesome @electricfeet, thanks! I've got the site restored to a previous version. Am going to dig in and work on your suggestions tomorrow...... Thanks everyone!

  9. Andrea Reed
    Member
    Posted 7 months ago #

    @ElectricFeet, Well I had a full version of functions.php in the Child Theme directory. I removed that. Do you think that would fix it?

  10. WPyogi
    Volunteer Moderator
    Posted 7 months ago #

    Yes, quite likely - copying a functions file to a child theme generally causes major problems. You may want to review:

    http://codex.wordpress.org/Child_Themes#Using_functions.php

Reply

You must log in to post.

About this Theme

About this Topic