WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error after installing 3.7.1 (16 posts)

  1. FRA NWR Webmaster
    Member
    Posted 10 months ago #

    I clicked on update wordpress on all of my sites and on http://fra-nwregion.org the following popped up and it is all I can get for any page on the domain.

    Fatal error: Call to undefined function wp_using_ext_object_cache() in /home/crcamel/fra-nwregion.org/wp-includes/option.php on line 445

    all other sites either updated with no issues and the others were auto update with no issues. How do I fix this??

    Thanks

  2. Abhishek Ghosh
    Member
    Posted 10 months ago #

    Can you perform a manual upgrade? Here is official guide.

  3. WPMU DEV
    Member
    Posted 10 months ago #

    Hi @FRA NWR Webmaster,

    I hope you are well today and thank you for your question.

    Do you have WP_DEBUG set to false in your wp-config.php file?
    If you do then please set it to true so that we can get some more information about this error.

    Best Regards,

  4. FRA NWR Webmaster
    Member
    Posted 10 months ago #

    I am looking over the manual instructions now. How can I deactivate the plugins when I cannot get into my dashboard due to the current error?

    I FTP'd into the site and set WP-DEBUG to true. Will change it back this afternoon.

  5. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Hi @FRA NWR Webmaster,

    To quickly get access back to your site, you can rename your /plugins/ folder in /wp-content/ to something like /plugins-backup/.

    WordPress loads plugins from the standard /plugins/ folder. And potentially, you could place files from the backup folder into the /plugins/ folder one by one to see where the problem's coming from.

    Cheers,
    DavidM

  6. WPMU DEV
    Member
    Posted 10 months ago #

    Hi @FRA NWR Webmaster,

    Thanks for reply.

    When you set WP-DEBUG to true, now i can see following Notice on the page Notice: Undefined index: posts_per_page in wp-content/plugins/media-category-library/classes/media-category-library.php on line 57

    It seems like the plugin media-category-library is causing some problem. Can you just try deactivating all plugins by renaming plugins folder using FTP or SSH access as described by @Ugotsta in previous reply.

    Best Regards,

  7. FRA NWR Webmaster
    Member
    Posted 10 months ago #

    alright I renamed the plugins folder ad I am still getting the original error of

    Fatal error: Call to undefined function wp_using_ext_object_cache() in /home/crcamel/fra-nwregion.org/wp-includes/option.php on line 445

    Any other suggestions??

    Thank you for all of your help so far, I appreciate it.

  8. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Interesting, my first thought was that it's probably due to a file corruption that occurred during the upgrade. But then I found the following thread here.
    http://wordpress.org/support/topic/wp37-update-fails-to-complete

    Perhaps the maintenance release will sort that for you?
    http://wordpress.org/news/2013/10/wordpress-3-7-1/

    Cheers!
    DavidM

  9. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Yikes, scratch that, that does seem to be the version you noted in the OP.

    Okay, so I wonder if you could download a hard copy to your computer and extract and overwrite just the /wp-includes/ folder on your server with the one from that file?

    Maybe that will sort it? If it's a matter of a simple file corruption, it usually does.

  10. FRA NWR Webmaster
    Member
    Posted 10 months ago #

    David,
    I just started extracting the files for a manual overwrite via FTP. I will post here once I complete the instructions from the manual upgrade page.

    Backing up WP-Content now to dropbox as I type this

  11. David
    WPMU DEV Support Staff
    Posted 10 months ago #

    Sure thing. I only mentioned /wp-includes/ because people usually don't alter those files. those or /wp-admin/, which in this case might also be good to replace.

    Looking forward to seeing this working for ya!

  12. FRA NWR Webmaster
    Member
    Posted 10 months ago #

    FIXED!!! replaced the wp-includes files and I'm back in business.

    I have a lot of posts that need to go live this week with veterans day coming up on Monday.

    Thank you for all of the help!

    Pete
    FRA NW Region Webmaster
    http://fra-nwregion.org

  13. kuyabiye
    Member
    Posted 6 months ago #

    i replaced the wp-includes, it fixed but after some time, i am getting that error again. I tried to update 3.8 with manual upgrade, still getting this error. any help? thanks in advance.

  14. David
    WPMU DEV Support Staff
    Posted 6 months ago #

    Hi @kuyabiye,

    That's really strange that it worked initially, then the error showed back up.

    If you replace /wp-includes/ again, does that fix it once again?

    If so, and if it comes back up again, something must be changing things in that folder.

    If it occurs rather quickly, would it be possible to deactivate plugins and use a default theme like Twenty Fourteen to see if the issues persists with that?

    I'll be happy to help, so if you could provide that additional info, I'll gladly see what more I can find for you.

    Cheers,
    David

  15. kuyabiye
    Member
    Posted 6 months ago #

    Yes it fixes again, then after a couple of days it happens again. it goes like that.

    i am using lots of plugins, i thought it can be wp super cache plugin. i disabled the wp super cache plugin and waiting that if it will be happened again. unfortunately it did not occur quickly. it has been 3 days, it is working now.

    thanks.

  16. WPMU DEV
    Member
    Posted 6 months ago #

    Hi @kuyabiye,

    Glad it's working for you now :)

    If you face the problem again or i can be of any further assistance please don't hesitate to ask :)

    Cheers,

Reply

You must log in to post.

About this Topic

Tags