WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error after fresh new install (5 posts)

  1. pauldts
    Member
    Posted 2 years ago #

    I just installed a fresh new wordpress copy.
    I get this error right in the installation process. I managed to install it by replacing all the files except wp-content.
    It works after I do that, but after first click or page refresh, I get this error:
    "Fatal error: Cannot redeclare class Walker_Page"

    I also noticed that it also works one time, before I do a click or refresh if I restart my apache server.

    Please help

  2. RichardWPG
    Member
    Posted 2 years ago #

    My I know what is the walker_page referring to? Did you install a new theme or new pkugins before that?

  3. Tara
    Member
    Posted 2 years ago #

    try:

    -deactivating ALL plugins temporarily to narrow down the problem. If the problem goes away, activate them individually (one-by-one) to find the problematic plugin.

    If you don't have access to your admin area, try deactivating them manually via FTP or phpMyAdmin.

    You may also use this to check if a plugin is compatible with the current WP version

    -switching to the default theme (that came with your version of WP) for a moment by renaming your current theme's folder in wp-content/themes. The idea is to force WordPress to fall back to the default theme to rule out any theme-specific issue.

    If you don't have access to your admin area, then access your server via FTP or SFTP or whatever file management application your host provides.

  4. pauldts
    Member
    Posted 2 years ago #

    Walker_Page is reffering to wp-includes/post-template.php.
    I didn't install any plugin or theme. It's absolutely clean.
    I will try to deactivate the default plugins and let u know how this is going.

  5. pauldts
    Member
    Posted 2 years ago #

    Same problem. Disabled plugins and using default theme.
    If this helps, I had to manually create the wp-config.php file. I checked file and folder permissions and that looks fine.
    Also, I installed the same new version on my other shared server and that worked perfect. My guess is that has something to do with php version (PHP Version 5.3.5) or php ini settings from my vps.
    I have set memory_limit to 99mb which is more than enough I think.

    Any other thoughts?

Topic Closed

This topic has been closed to new replies.

About this Topic