WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Fatal error after changing theme to Platform Theme (6 posts)

  1. Suan
    Member
    Posted 3 years ago #

    I have a blog previously on the Antisocial theme and one of my plugins included Cincopa.

    I decided to change the theme to Platform Theme (flatline, I think?) and when I clicked the "activate" theme button, the entire screen vanished and I received this error message:

    Fatal error: Cannot redeclare improved_trim_excerpt() (previously declared in /home/teops/public_html/TammyAndMummy.com/wp-content/plugins/post-rich-videos-and-photos-galleries/wp-media-cincopa.php:440) in /home/teops/public_html/TammyAndMummy.com/wp-content/themes/platform/core/library/library.functions.php on line 467

    Now my website: http://tammyandmummy.com is completely blank. And I can't even login to wordpress because the error message remains on my wp-admin page: http://tammyandmummy.com/wp-admin

    Can someone please help me? I'm not familiar with all this tech stuff and need to be guided step-by-step. If I really have no other option but to restart from scratch, how do I do so? More importantly, is there some way for me to back up my previous blog posts?

    Appreciate any help I can get. Thank you.

  2. 123milliseconds
    Member
    Posted 3 years ago #

    delete platform theme folder

    WP will use its default 2010 theme

    pick another theme to download

  3. Suan
    Member
    Posted 3 years ago #

    Thanks. Sorry but do I delete it at public_html?

  4. 123milliseconds
    Member
    Posted 3 years ago #

    NOT public_html

    delete the platform folder in

    public_html/wp-content/themes/

  5. Chip Bennett
    Theme Review Admin
    Posted 3 years ago #

    You have a conflict with a function called improved_trim_excerpt(). Both your Theme and the Post Rich Videos and Photos Galleries Plugin are trying to declare (define) this function.

    You will need to deactivate either the Theme or the Plugin.

    If you cannot access your Dashboard, then you will need to use an FTP client. You will find the Theme files here:

    /home/teops/public_html/TammyAndMummy.com/wp-content/themes/<theme-name>
  6. Suan
    Member
    Posted 3 years ago #

    Thanks for much 123milliseconds and Chip. Problem resolved! I decided to just delete the theme.

    Thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic