WordPress.org

Ready to get started?Download WordPress

Forums

Fatal Error after Automatic upgradation to ver 3.2 (10 posts)

  1. smartmwp
    Member
    Posted 3 years ago #

    Hi!

    I upgraded to the latest version 3.2 from 3.1.4 and I think the present version is conflicting with buddypress forums plugin.

    Fatal error: Call to undefined method wpdb::WPDB() in /home/smomz/public_html..../wp-content/plugins/buddypress/bp-forums/bp-forums-bbpress.php on line 144

    Please help!

    Sonia

  2. smartmwp
    Member
    Posted 3 years ago #

    OK, I removed the buddypress plugin and was able to access my new 3.2 version dashboard. I again uploaded the latest 1.2.8 version of BP and again the same error came. Now I have uploaded the version 1.2.5.2 of BP and now my site is working. Thank God!

  3. ablondeabroad
    Member
    Posted 3 years ago #

    Hi There,

    I also tried to upgrade yesterday and nothing seemed to work.

    Now when I try and log into my dashboard I get the following error message:

    Fatal error: Call to undefined function is_network_admin() in /home/lucy/public_html/wp-admin/admin-header.php on line 16

    Please help!

    I am not very tech savvy!

    Thanks
    Lucy

  4. Dion Hulse
    WordPress Dev
    Posted 3 years ago #

    Hi ablondeabroad,
    Your issue sounds like it's been caused by a partial upgrade of WordPress, ie. not all the files were updated properly, probably because it got interupted half way through.

    You will need to perform a manual update, in order to do this, you'll need to download the latest version of WordPRess from WordPress.org, and FTP the files over the top of your existing ones, See this codex article on how to manually update.

  5. ablondeabroad
    Member
    Posted 3 years ago #

    I have tried to re-download wordpress but it just opens a folder with files in.. is this right... I'm not sure what to do next

  6. dubya1337
    Member
    Posted 3 years ago #

    I have the same problem as smartmwp above. So the solution is to revert to an earlier version of BuddyPress?

  7. dubya1337
    Member
    Posted 3 years ago #

    Buddypress 1.2.9 is out: http://buddypress.org/2011/07/buddypress-1-2-9/
    I renamed my /buddypress folder to /buddypress-old, and uploaded 1.2.9 to /buddypress.
    Whew! Disaster averted :D

  8. michelle cohen
    Member
    Posted 3 years ago #

    Ok, help! I tried to do an "auto upgrade" (via the button, i guess it's a plugin? it's not an option on my other sites so must be something i added) to 3.2 on my testing site (SO glad i have one) furgarden.com, and I first got stuck in the "scheduled maintenance" screen, and now it is totally stuck with this error screen:

    Fatal error: Cannot redeclare wp_maybe_load_embeds() (previously declared in /home/cityrat/furgarden.com/wp-includes/functions.php:3112) in /home/cityrat/furgarden.com/wp-includes/media.php on line 1415

    and i can't get to the dashboard, etc.
    I'm not the least tech savvy person but I'm no database whiz; also, i have lots of plug-ins running (though i don't think Buddypress is one of them).

    What should i do?
    thanks!

    The theme I'm using is Magatheme Pro
    http://www.gazellethemes.com/magatheme-minimal-magazine-theme-for-wordpress/
    but that shouldn't matter, should it?

    Also: Dreamhost is my host service.

  9. michelle cohen
    Member
    Posted 3 years ago #

    ok, eek.
    I followed the advice here:
    http://nooshu.com/wordpress-3-2-auto-update-fail

    and deleted the wp-admin and wp-includes folders on the site, downloaded 3.2 manually and uploaded those folders, and now I get THIS error message:

    Warning: require(/home/cityrat/furgarden.com/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home/cityrat/furgarden.com/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required '/home/cityrat/furgarden.com/wp-includes/load.php' (include_path='.:/usr/local/lib/php:/usr/local/php5/lib/pear') in /home/cityrat/furgarden.com/wp-settings.php on line 21

    HELP!

    does this upgrade fix
    http://wordpress.org/extend/plugins/ftp-upgrade-fix/
    work for 3.2?

  10. michelle cohen
    Member
    Posted 3 years ago #

    ADDENDUM:
    Whew. It seems to have been fixed. I tried the plugin as above, but it wasn't even activated ("You are running WordPress 3.2 which doesn't need the FTP Upgrade Fix plugin. You can deactivate and delete the plugin."); when the admin panel came back up i activated it. Maybe it took a while to update the new files that i replaced.

    However:
    I get this message:
    "An automated WordPress update has failed to complete - please attempt the update again now."
    When i try to do the upgrade again, it tells me i'm already running the newest version. etc. etc.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags