WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Fatal error (6 posts)

  1. cpagh
    Member
    Posted 11 months ago #

    Hi

    When I open the Control Panel the following message under the rubric of WP e-Commerce News arrives.

    "Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 491520 bytes) in .../wp-includes/SimplePie/Item.php on line 1400"

    Does anyone know what caused it and how I solve the problem?

    Thanks in advance

    Best regards
    Christian

    http://wordpress.org/plugins/wp-e-commerce/

  2. Jacezilla
    Member
    Posted 11 months ago #

    Do you happen to have an infinite loop running on line 1400?

    It's difficult to really help without any code here.

  3. cpagh
    Member
    Posted 11 months ago #

    Hello

    I have not changed the code, but have only installed a standard edition (in Danish) of WP and WP e-Commerce plus some other plugins.

    When I disable the WP e-Commerce, the error disappears.

    I have uninstalled and reinstalled WP e-Commerce, but with the same result.

    I try to find the code.

    Best regards
    Christian

  4. cpagh
    Member
    Posted 11 months ago #

    Here is the code ... I have marked the beginning of line 1400 with black ... hope it can help.

    // HASHES
    			if ($hashes_iterator = $this->get_item_tags(SIMPLEPIE_NAMESPACE_MEDIARSS, 'hash'))
    			{
    				foreach ($hashes_iterator as $hash)
    				{
    					$value = null;
    					$algo = null;
    					if (isset($hash['data']))
    					{
    						$value = $this->sanitize($hash['data'], SIMPLEPIE_CONSTRUCT_TEXT);
    					}
    					if (isset($hash['attribs']['']['algo']))
    					{
    						<strong>$algo</strong> = $this->sanitize($hash['attribs']['']['algo'], SIMPLEPIE_CONSTRUCT_TEXT);
    					}
    					else
    					{
    						$algo = 'md5';
    					}
    					$hashes_parent[] = $algo.':'.$value;
    				}
    			}
  5. cpagh
    Member
    Posted 11 months ago #

    NB. It seems that the problem disappears when I disable my plugin "SEO Ultimate".

  6. cpagh
    Member
    Posted 11 months ago #

    Information from Wordfence forums are as follows:

    I think you have to adjust that in httpd.conf or php.ini I cant rememeber which right off. Its just using a lot of memory. Alternatively, you should be able to set this in your wp-config.php file like this: define('WP_MEMORY_LIMIT', '96M');

    Unfortunately, it does not seem that the "define ..." works and my webhotel can / will not increase the available memory.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.