WordPress.org

Ready to get started?Download WordPress

Forums

Woocommerce CSV importer
[resolved] "Fatal error" (6 posts)

  1. gonzaromano
    Member
    Posted 10 months ago #

    Hi, I´ve been using your plugin for a while now, buy yesterday I received a fatal error that I´ve never received before:

    "Fatal error: Cannot use object of type WP_Error as array in /www/repuestosrodi.com/htdocs/wp/wp-content/plugins/woocommerce-csv-import.0.7.3/include/woocommerce-csvimport-functions.php on line 224"

    I know that version 0.7.3 isn´t the latest version, but is the one I prefer because of my dataset, and this error never ocurred before. I tried uninstalling and reinstalling it back, but the error keeps showing.

    Any ideas?

    Thank you in advance!
    http://www.repuestosrodi.com

    http://wordpress.org/plugins/woocommerce-csvimport/

  2. joelkriteman
    Member
    Posted 10 months ago #

    Hello

    I don't know the specific answer to your question I'm afraid but I can tell you a couple of things that should help.

    If you are running an old version of a plugin that was working fine and then stopped even though you didn't update it, the next logical question I think is did you update anything else?

    WordPress, Woocommerce?

    If you updated one of these and not the plugin then that could be the problem.

    Second thing is that WooCommerce have their own support forum and ticketing process. I've used it many times and it's very good - and quick.

    My guess is that they will tell you to update everything - and keep it up to date.

    Otherwise you are looking to get hacked.

    Hope that helps.

    Joel

  3. gonzaromano
    Member
    Posted 10 months ago #

    Hi Joel! Thanks for the tips!

    My reason for running an old version of the plugin is simple: I arranged my dataset to support the csv format required for the older versions. Since version 1.0 was released, the format was modified, and the header is always asked, I just can´t understand the logic of the newer versions.

    Anyway, I updated the plugin to its latest version and now, WP disabled the plugin because there is an error with its files!

    Truly, I didn´t updated anything, I always import a couple of csv, and in the middle of one of those files, it just broke down. When it happened, 1 file was imported correctly.

    I ended up uninstalling the plugin until I can get help to getting it to work, whatever version!

    Thanks again!
    Gonza

  4. joelkriteman
    Member
    Posted 10 months ago #

    Hi Gonza

    If you haven't updated anything else, not WordPress, WooCommerce or any other plugins then sounds like your problem is something else.

    I haven't used the plugin you are talking about but I had an issue with a different WooCommerce csv plugin a while ago that was being caused by non web safe characters in the data set. I'm just guessing here though. Incidentally that problem was then resolved in a subsequent update of the plugin - further proof if you need it that it's good to keep everything up to date!

    It's a pain when plugins or WordPress itself updates and causes something to break which you then have to spend time and effort fixing but it's a necessary part of running a WordPress site.

    Like tending a garden I guess...

    Good luck with resolving your issue.

    Joel

  5. gonzaromano
    Member
    Posted 10 months ago #

    Finally found it!!!

    The subcategories had misteriously changed from "->subcat1" to "->" so the error was indicating the absence of subcategorie.

    Thanks Joel!

  6. joelkriteman
    Member
    Posted 10 months ago #

    Excellent :-)

Reply

You must log in to post.

About this Plugin

About this Topic