WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Column Widgets
[resolved] Fatal Error (2 posts)

  1. Kathy_Goss
    Member
    Posted 10 months ago #

    I believe I followed all of the directions. I created a couple of sample custom post widgets and inserted them in your sidebar widget and added the shortcode to the page. I received the following error message:
    Fatal error: Allowed memory size of 67108864 bytes exhausted (tried to allocate 42 bytes) in /home/content/31/7500231/html/XXX/wp-includes/post.php on line 595

    http://wordpress.org/extend/plugins/responsive-column-widgets/

  2. miunosoft
    Member
    Plugin Author

    Posted 10 months ago #

    Hello there,

    It simply means WordPress can not allocate more space in memory(RAM) to execute or continue running process. So try increasing the memory allocation for PHP. See these relevant posts.

    http://wordpress.org/support/topic/fatal-error-allowed-memory-size-of-67108864-bytes-exhausted-1
    http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    As described in the above posts, you need to manually edit the PHP file. However, the plugin has a setting for it. Go to Appearance -> Responsive Column Widgets -> General Options -> Option Management -> Attempt to Override Allocated Memory Size, and set enough size there. I suppose 128MB should be enough.

    Also, you should upgrade your PHP to 5.3 or above if you are using a lesser version. It has better memory handling and I've seen many occasions that dramatically decrease the memory usages.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.