WordPress.org

Ready to get started?Download WordPress

Forums

  1. mmartinovich
    Member
    Posted 11 months ago #

    Everything worked great and ufter update to version 3.4.10 i get this error and could not activate plugin...

    Warning: require_once(/mnt/webc/d3/17/527517/htdocs/sturm-edv/wp-content/includes/upgrade.php) [function.require-once]: failed to open stream: No such file or directory in /mnt/webc/d3/17/527517/htdocs/sturm-edv/wp-content/install.php on line 39

    Fatal error: require_once() [function.require]: Failed opening required '/mnt/webc/d3/17/527517/htdocs/sturm-edv/wp-content/includes/upgrade.php' (include_path='.:/opt/RZphp52/includes') in /mnt/webc/d3/17/527517/htdocs/sturm-edv/wp-content/install.php on line 39

    Please help!

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Handoko
    Member
    Posted 11 months ago #

    It sounds something very bad has happened. My suggestion is to reinstall the plugin.

    First you need to uninstall the plugin, but some setting information may still being kept in its database. So you need to do a complete uninstallation. Read more here (especially item no. 2):
    http://wordpress.org/support/topic/after-log-in-screen-goes-blank

  3. mmartinovich
    Member
    Posted 9 months ago #

    Hi,

    after uninstalling i did not find these files in DB
    - bit51_bwps_data
    - bit51_bwps
    - bwps_file_log

    So I just gave up on Better WP Security but after i updated WP to version 3.5.2 I cant login to dashboard anymore... I get this again:

    Warning: require_once(/mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-content/includes/upgrade.php) [function.require-once]: failed to open stream: No such file or directory in /mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-content/install.php on line 39

    Fatal error: require_once() [function.require]: Failed opening required '/mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-content/includes/upgrade.php' (include_path='.:/opt/RZphp52/includes') in /mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-content/install.php on line 39

  4. Handoko
    Member
    Posted 9 months ago #

    It seems you have enable the "change wp-content directory" feature in Better WP Security. This feature often can't work correctly with some other plugins. Did you really enable the change wp-content directory?

    Once you have enabled the feature, there is no disable or revert it option. Some suggest you can manually edit the database for bringing it back to normal, but it won't be easy I think. Fortunately, which I've ever tried several times, we can make it works by copying the (missing) files to the new directory.

    If the "change wp-content directory" is the cause of your problem, you may try:

    1. Locate the missing files

    It seems your site has problem with these files:
    - .../wp-content/includes/upgrade.php
    - .../wp-content/install.php

    2. Find the new "wp-content" directory

    Do you still remember what is your new wp-content directory? I mean the new name you provide when you activated the feature? If you can't remember it, then you may need to use File Manager or FTP to examine your website's directory structure.

    3. Copy the file from your new wp-content directory to (the old) "wp-content" directory

    For example if your new wp-content directory is "new-content". What you need to do is:

    Copy the file in: .../new-content/includes/upgrade.php
    To: .../wp-content/includes/upgrade.php

    and

    Copy the file in: .../new-content//install.php
    To: .../wp-content/install.php

    Good luck!

  5. mmartinovich
    Member
    Posted 9 months ago #

    I dont remeber enabling that option. I'm 99% sure I didnt.
    My /wp-content/install.php is still there but /wp-content/includes folder is missing???

  6. Handoko
    Member
    Posted 9 months ago #

    It seems you need to forcing the plugin to reinstall.

    1. Make backup, especially the .htaccess file
    2. Delete the plugin folder (or rename or move it to some where)
    3. Remove lines between #BEGIN and #END Better WP Security in your .htaccess file
    4. Login to your website backend
    5. Uninstall the plugin
    6. Reinstall and activate the plugin

  7. mmartinovich
    Member
    Posted 9 months ago #

    I get this again...

    Fatal error: Cannot redeclare upgrade_all() (previously declared in /mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-admin/includes/upgrade.php:331) in /mnt/webo/a2/17/527517/htdocs/sturm-edv/wp-content/includes/upgrade.php on line 411

  8. Handoko
    Member
    Posted 9 months ago #

    I don't think your issue is related with this Better WP Security. Can you please tell me what make you think that this plugin cause the errors? Perhaps you can try to disabled (or uninstall) it for a while and see if the errors still occur.

Reply

You must log in to post.

About this Plugin

About this Topic