WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce SagePay Direct Payment Gateway
[resolved] Fatal error (18 posts)

  1. monzu02
    Member
    Posted 1 year ago #

    Hello,

    i get this error when i tried to active this plugin

    Fatal error: Class 'WC_Payment_Gateway' not found in /home/XXX/public_html/wp-content/plugins/sagepay-direct-for-woocommerce-payment-gateway/ds-sagepay-direct.php on line 109

    My WordPress 3.4.2 and
    WooCommerce Version 1.3.2.1

    Thank you
    M

    http://wordpress.org/extend/plugins/sagepay-direct-for-woocommerce-payment-gateway/

  2. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,
    WC_Payment_Gateway is a WooCommerce class that 3rd party payment gateways extend. Check that WooCommerce is activated.

    I would recommend you upgrade to Version 2 on WooCommerce or if that is not possible try using an earlier version of this plugin 0.1.5 or 0.1.4 which would have worked with your version 1.3.2.1.

    regards

    Steve

  3. monzu02
    Member
    Posted 1 year ago #

    Thank you for your reply but is it safe?

  4. perkinwarbeck2013
    Member
    Posted 1 year ago #

    I, too, would like to know if it is safe.

  5. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    is what safe?

  6. monzu02
    Member
    Posted 1 year ago #

    @swicks will you please let us know its safe to use or not? Thank you

  7. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    @monzu02 what is safe ? Please explain yourself, little more explanation please? Thank you.

  8. monzu02
    Member
    Posted 1 year ago #

    @swicks as i have to use use older copy of this plugin so is there any security issue? and its safe to use in the website. is there any risk for hack or any problem?

    Thank you
    M

  9. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    In all release updates of this plugin there has been no security patches, they have been feature enhancements and modifications to the procedure calls to WooCommerce as it evolves.

    I'm not aware of any security issues with any of the releases.

    best regards

    Steve

  10. monzu02
    Member
    Posted 1 year ago #

    Thank you for your reply

    i had tried 0.1.4 (svn) but getting this error

    please check below :(

    atal error: Class 'WC_Payment_Gateway' not found in /home/xxx/public_html/wp-content/plugins/sagepay-direct-for-woocommerce-payment-gateway/ds-sagepay-direct.php on line 97

    Thank you
    M

  11. monzu02
    Member
    Posted 1 year ago #

    now .0.1.1 make this error

    please advice.

    Fatal error: Class 'WC_Payment_Gateway' not found in /home/xxxx/public_html/wp-content/plugins/sagepay-direct-for-woocommerce-payment-gateway/class-wc-sagepaydirect.php on line 39

  12. swicks
    Member
    Plugin Author

    Posted 1 year ago #

    Hi
    I just looked through the previous versions of woocommerce on Github to try to reproduce this issue. It turns out that version 1.4 and above only support WC_Payment_Gateway class it was renamed from woocommerce_payment_gateway on your version.

    Apologies it will not work with your version of Woocommerce.

    Regards

    Steve

  13. thaiguy
    Member
    Posted 11 months ago #

    Hi there I am having the same problem with this showing.

    Fatal error: Class 'WC_Payment_Gateway' not found in /home/content/16/10589616/html/wp-content/plugins/nochex-woocommerce-gateway/wc-nochex.php on line 13

    I'm new to wordpress and all that I did was upgrade the plugins...
    And now i cannot visit the site or even get on the wp-admin login page to change it back.

    I also can't connect through FTP (critical error) but even if I did I would not know what to do next.

    Kindest Regards

    Peter

  14. thaiguy
    Member
    Posted 11 months ago #

    Hi there I am having the same problem with this showing.

    Fatal error: Class 'WC_Payment_Gateway' not found in /home/content/16/10589616/html/wp-content/plugins/nochex-woocommerce-gateway/wc-nochex.php on line 13

    I'm new to wordpress and all that I did was upgrade the plugins...
    And now i cannot visit the site or even get on the wp-admin login page to change it back.

    I also can't connect through FTP (critical error) but even if I did I would not know what to do next.

    (www.ellie-apparel.com)

    Kindest Regards

    Peter

  15. swicks
    Member
    Plugin Author

    Posted 11 months ago #

    You need to use WooCommerce version 1.4 or later.

    Your error doesn't relate to this payment gateway.

    Best regards

    Steve

  16. monzu02
    Member
    Posted 11 months ago #

    WOW it takes 4 months for resolved!!!

  17. swicks
    Member
    Plugin Author

    Posted 11 months ago #

    @monzu02 This WAS resolved 4 months ago - please read the thread before responding!!!

    I was responding to a new post on an old thread.

  18. daniel dias
    Member
    Posted 8 months ago #

    ola!! estou com esse mesmo poblema com ( fatal erro ) como faço para ter asseço au admitrador pos ñ mas concigo entrar

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.