WordPress.org

Ready to get started?Download WordPress

Forums

Fatal: class 'translations' not found, after 2.6 upgrade to 2.8 (10 posts)

  1. petevannuys
    Member
    Posted 5 years ago #

    I did the following:

    Deactivated plugins.

    Deleted all files and folders from old wp-admin and wp-includes folder.

    Extracted 2.8.1 and uploaded w/ ftp the contents of wp-admin and wp-folders.

    Didn't do anything to my old wp-content folder.

    got this error:

    Fatal error: Class 'Translations' not found in /home/p14l39fs/public_html/wordpress/wp-includes/l10n.php on line 408

    p14139fs is the name of my database backup on my desktop... it appears to reside higher up in the path than my wordpress directories. What's that mean?

    In the wp-includes folder I have the pomo folder, which has
    translations.php
    streams "
    po "
    mo "
    entry "

    Someone suggested I hadn't uploaded the subdirectories properly. How should I have done it?

    Please advise.... suggestions?

    Thank you.

  2. fldtrace
    Member
    Posted 5 years ago #

    Try activate the default theme, overwrite wp-acontent as well with files from new version and see if that is working.

    I believe you need to make updates within your theme files too.

  3. adiaha33
    Member
    Posted 5 years ago #

    I am having the same problem, has this been resolved for you?

    I can't access the Dashbord because there is an error?

    What can I do to get my site back up?

    Thanks.
    adiaha

  4. whooami
    Member
    Posted 5 years ago #

    This error is caused by wp-includes/pomo/ and all the files within it not being uploaded.

  5. adiaha33
    Member
    Posted 5 years ago #

    I checked and checked again. The downloaded version and the uploaded versions are the exact same. Is there anything else that may cause this condition? Please help.

  6. mnr
    Member
    Posted 4 years ago #

    I had this problem. I re-uploaded wp-includes/pomo
    and some other wp-includes files which I don't recall.
    Best thing is to reupload the entire wp-includes.

    Problem was solved for me.

  7. adamdicarlo
    Member
    Posted 4 years ago #

    I had this problem too. The problem was that after running the auto upgrader, the wp-includes/pomo/ directory was drwx------, so not accessible by the web server, which isn't the owner of the files.

    The solution for me was to run chmod go+rx wp-includes/pomo in an ssh session.

    Bug in the auto-upgrader, maybe?

  8. emilychang
    Member
    Posted 4 years ago #

    I had the same fatal error. Also tried to reupload the /pomo directory, checked permissions. Neither of those fixed it.

    Turned out to be wp-settings.php - reuploaded that and it worked (as documented here: http://wordpress.org/support/topic/288685).

    Hope that helps!

  9. Lowrobb
    Member
    Posted 4 years ago #

    Hai Emily, that solves my problem. Thanks! :)

  10. asimpkin
    Member
    Posted 4 years ago #

    did an ftps update of all files and had the same problem. wp-includes/pomo/ is distributed with folder permissions set to 700.
    chmod 755 wp-includes/pomo
    Problem solved.

Topic Closed

This topic has been closed to new replies.

About this Topic