WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure contact form (26 posts)

  1. glreber
    Member
    Posted 2 years ago #

    I am having issues with the Fast Secure contact form. I host thru Godaddy and recently changed my hosting from windows deluxe to linux 4g. I had the plugin working previously but then after the switch the captcha image stop displaying. I then tried to uninstall and reinstall and now it get the following errors.

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/04/8260904/tmp/sess_hsradrqf1pme0rn46nscmftbd7, O_RDWR) failed: No such file or directory (2) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php on line 1431

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/04/8260904/html/garyreber/wp-content/plugins/si-contact-form/si-contact-form.php:1431) in /home/content/04/8260904/html/garyreber/wp-includes/pluggable.php on line 934

    Warning: Unknown: open(/var/chroot/home/content/04/8260904/tmp/sess_hsradrqf1pme0rn46nscmftbd7, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

    Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

    I have contacted godaddy but they say it is not on the server side it is a plugin issue. Any suggestions would be appreciated. I saw a old post talking about this issue and being related to the php session temp location but again Godaddy said it is nothing on their side.

    Regards,
    Gary

  2. hattendesign
    Member
    Posted 2 years ago #

    It is a Godaddy issue but they won't help :( -> This is usually the case with Godaddy.

    Here's a quick fix..

    Create a new folder on your root directory and call it sessions
    Change its permissions to 777 (Check all the options from GD's control panel viewable - writable - executable )

    At this point you should have a folder like yourdomain.com/sessions

    open wp-config.php with your text/code editor and put

    session_save_path('/home/content/04/8260904/html/sessions');

    for anyone else with the same problem just replace "04/8260904" with your GoDaddy user folders.

    For enhanced security put the folder inside your host's root out of public view. (I'm not sure if the "web viewable" box in GoDaddy will help with this)

    You may want to change the name sessions to something unique too.

    Cheers

  3. hattendesign
    Member
    Posted 2 years ago #

    I forgot to mention that the code should got on line 2 right below

    <?php
    session_save_path('/home/content/04/8260904/html/sessions');
    /**
     * The base configurations of the WordPress.
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information
     * by visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation. You don't have to use the web site, you can just copy this file
     * to "wp-config.php" and fill in the values.
     *
     * @package WordPress
     */
  4. glreber
    Member
    Posted 2 years ago #

    thanks but i made the change as suggested and it still points to the same session folder (tmp) and has the same errors.

  5. hattendesign
    Member
    Posted 2 years ago #

    What's your url?

  6. glreber
    Member
    Posted 2 years ago #

    I am actually trying something with Godaddy. I have changed my hosting plan to windows (w/php support) and then will be changing back to just linux servers again. I am thinking this will move me to another server that might not have the issues as when I originally started with them I had a windows/php supported account.

    Here is the link, it is a test site that i use to experiment with but it is hosted on the same as my other sites. thanks for the help.

  7. glreber
    Member
    Posted 2 years ago #

  8. hattendesign
    Member
    Posted 2 years ago #

    I see. You're trying to access the plugin test file directly. The test gives an error because it doesn't use wp-config.php

    The code I posted is a fix for the wordpress installation so any other php file which requires sessions would give out the same error.

    If you activate the plugin and use it within wordpress, it will work.

    To get rid of the error just add the same session_save_path code to the index.php in the captcha test.

    Looking into the form script, you'll also need to add the same session_save_path() to secureimage.php

    Captcha uses sessions and the file tries to create a session on the path specified by the server.

    Ideally, you shouldn't have to specify the save path but in your case (and the case of many) they don't seem to change when you switch OS.

  9. glreber
    Member
    Posted 2 years ago #

    thanks for the info I will keep this information. the package change with godaddy is now completed which moved me to another server and the plugin is now working as it did before. I am going to leave it on the windows based server for now (since it works) and maybe in the future change it back to pure linux.

    thanks again.

  10. hbbd
    Member
    Posted 2 years ago #

    thanks hattendesign I added the session_save_path('/home/content/04/8260904/html/sessions'); line with my user id and it fixed it.

    this post should be highlighted as I'm sure this impacts several Godaddy users. I had this on several websites after upgrading to 4GH. I guess it depends on the theme and plugin used but it fixed the issue.

    thanks

  11. glreber
    Member
    Posted 2 years ago #

    Yes thanks. As a follow up i had my sites migrated back to a different 4gh server and it does seem to be an issue with Godaddy's server/php setup. The above solution works and I have implemented. There is also another plugin that is pretty good for anti spam on forms and comments. WP Enmask.

    Thanks again hattendesign.

  12. Christine
    Member
    Posted 2 years ago #

    I just got this error when I set up a new blog (multisite). I DID switch servers a few weeks ago.

    All the other blogs work fine, it's only a problem for NEW blogs.

    I disabled the plugin for now because I don't have the time to do a bunch of coding every time wordpress upgrades and really don't need the headache.

    What exactly is it that's wrong with my new server and why does it only affect NEW blogs?

    Appreciate any suggestions,

    Christine

  13. hattendesign
    Member
    Posted 2 years ago #

    Christine,

    The reason for this error is that the default path to the session (tmp) folder is wrong or the folder does not exist.(or it's not accessible by the user)

    You can break it down by looking at the error...

    WP is looking for a folder inside
    '/var/chroot/home/content/11/1111111/tmp/'
    But your ROOT folder is actually
    '/home/content/11/111111/html'

    adding a folder called 'tmp' to your root account would probably solve this issue however, you cannot go beyond the html folder. In this case, html is your root folder so, you need to create your own tmp or session folder and redirect the server to it.

    Again this is a fix to a specific issue when you switch from windows to linux on Godaddy.

    If you need help with your multisite setup send me a link to one that has the error and I can probably point out where the issue is.

  14. Christine
    Member
    Posted 2 years ago #

    Thanks so much for your reply!

    I reactivated it so I could see the exact error, set up a new blog and it worked fine.

    So I'm guessing that it fixed itself, that somehow when I created the last new blog while it was deactivated a folder was created or "whatever."

    FYI, I was on a linux server before, just moved to a new host (not GoDaddy).

    I just went to the plugin site and I'm so impressed. Installed the form several years ago and hadn't looked at it since because it's just been working trouble free. It's amazing what all it can do.

    I just donated $10 and thanks for a plugin that works great and even comes with support!

  15. Christine
    Member
    Posted 2 years ago #

    I was sure I posted here a couple days with the exact error I got when I tried to approve a comment. I was just going to update to say that the error went away again yesterday and everything still works just fine.

    I have done NOTHING to my WP installation and am not aware of any changes at my server. This is very strange.

  16. Christine
    Member
    Posted 2 years ago #

    Another update:

    Did all sorts of work on blogs today without any problems until finally this evening I got the error again on all blogs except the main blog (multisite).

    Had my roomie check on his computer since he had also been working on the sites and he didn't mention any problems. Everything was fine for him. So I restarted my machine and bingo!

    Very odd, but I'm glad it's only ME getting the error and that restarting my computer fixes it.

  17. Lewis
    Member
    Posted 2 years ago #

    Hi, thanks for your help, but when I go to the index.php file, where exactly do I put the session code?
    thanks

  18. Lewis
    Member
    Posted 2 years ago #

    Ah sorry ive read the thread proparly now and ive added this:

    session_save_path('/home/content/88/8601388/html/sessions');

    in the wp-config.php file, however I get:
    Fatal error: Call to undefined function phpsession_save_path() in /home/content/88/8601388/html/wp-config.php on line 1

  19. Lewis
    Member
    Posted 2 years ago #

    This is the site:

    http://jakobbelbin.com/

  20. hattendesign
    Member
    Posted 2 years ago #

    You probl. put the session_save_path next to your <?php call
    <?phpsession_save_path(
    but it should be

    <?php
    session_save_path(
  21. Lewis
    Member
    Posted 2 years ago #

    Perfect, I put that in both files and it worked.

    Thank you so much!

  22. chasewong1976
    Member
    Posted 2 years ago #

    Dear Hattendesign,

    I am sorry but I really want to ask you some questions which troubled me a long time.

    I am from China, and days I bought a theme abundance from themeforest.net, and I installed it to my hosting( bought from Godaddy.com), it okay, but when I install the plugin of Woocommerce as instructed from the documentation, problem occured as below,

    Warning: session_start() [function.session-start]: open(/var/chroot/home/content/34/8666534/tmp/sess_5rto6eqcsdk8q5j9bvul681920, O_RDWR) failed: No such file or directory (2) in /home/content/34/8666534/html/wp-content/plugins/woocommerce/woocommerce.php on line 13

    Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/34/8666534/html/wp-content/plugins/woocommerce/woocommerce.php:13) in /home/content/34/8666534/html/wp-content/plugins/woocommerce/woocommerce.php on line 13

    Could you take a moment to help me fix this problem?! thank you so much!

    BEST REGARDS,

    CHASE

  23. dilipsrivastava88
    Member
    Posted 2 years ago #

    Hattendesign! Thanks a ton for your quick fix. Helped me a lot.

    Best,
    Dilip.

  24. dcwebman
    Member
    Posted 1 year ago #

    FYI, apparently GoDaddy is now familiar with this common problem. I had the same issue and was ready to start making code changes but followed this link I found on another post:
    http://www.fastsecurecontactform.com/session-start-error

    All I did was contact them as it suggested, they asked what plug-in I was trying to use, saw the error messages, and in a few minutes they said try it again. Errors gone!

  25. lcminnovations
    Member
    Posted 1 year ago #

    I was having this same problem. Thank you guys so much for the help!!!

  26. gdws
    Member
    Posted 1 year ago #

    thanks this worked for me with ipage.com hosting

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.