WordPress.org

Ready to get started?Download WordPress

Forums

Fast and Secure Contact form not sending email (5 posts)

  1. morphjk
    Member
    Posted 3 years ago #

    For some reason no matter what I try I can not get email from my fast and secure contact form.

    I have tried installing the wp-mail smtp but that doesn't help and nor do any of the other ones.

    None of them help with sending the email.

    I have it on two websites:

    http://www.morffew.net/?page_id=28
    http://www.howrahcofc.org.au/contact-us/

    Any suggestions?

  2. Mike Challis
    Member
    Posted 3 years ago #

    There can be many causes. To find out what is the cause some troubleshooting will be required.

    Begin with wp-mail smtp disabled.

    Please try each fix and answer each question down the list, stop and let
    me know if you get it working.

    Try the email test on the contact form plugin page. Send the test to the
    same email address as your contact form does. What is the result?
    success or fail?
    After you sent the test email, what did it show on the screen?
    there should be a yellow box at the top "Test Message Sent Be sure to
    check your email to see if you received it." If it displays anything
    about failing, your web server mail function might be broken.

    When you installed WordPress did you get a welcome email to your admin
    address?
    Do you receive other mails like comment notifications from WordPress?

    The problem could be after the email is sent. It could be a mail
    delivery problem.

    Some web hosts restrict sending mail unless the "From" address is a
    valid address on the same domain.
    Try step 3 of the "email not working" in the FAQ
    http://wordpress.org/extend/plugins/si-contact-form/faq/

    Check that your "email to" address is correct and that the email has not
    gone into a spam filter somewhere.
    You may need to contact your web host for support with the mail delivery
    problem. Check with your hosting provider or mail provider that the
    emails aren't being caught in their spam filter.

    Try using PHP to send the mail instead of the WordPress mail function.
    On the plugin settings page you will find this setting: "Send E-mail function:", try setting this to "PHP", then test the form again. In some cases, this will resolve the problem.

    Some people report success with step 4 of the "email not working" in
    the FAQ
    http://wordpress.org/extend/plugins/si-contact-form/faq/

    If none of this worked, answer the questions above and let me know.
    I might have more ideas. If you got it working what was it?

    Mike

  3. morphjk
    Member
    Posted 3 years ago #

    Do you receive other mails like comment notifications from WordPress?

    I must admit that I didn't receive any notification from the comment that was made yesterday.

    I'll run through the options after work and see what happens.

  4. morphjk
    Member
    Posted 3 years ago #

    Well it turns out I can receive a test email to my ISP's email address but I don't receive the one to my main email address which is hosted by google apps.

    I've checked junk/spam folders and there is nothing there.

    So I'm not sure what is going on. My web host made sure all was fine on the server and said it was.

    So I then found my ISP's email address works but not my google apps email which is what I use on my site and the church site.

    Do you know how I fix it? I tried setting the from email and adding to my contacts.

  5. morphjk
    Member
    Posted 3 years ago #

    Fixed. It was sending email local and not to the remote server. Sorted that in cPanel and all is good again

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags