WordPress.org

Ready to get started?Download WordPress

Forums

FAQ Plugin (129 posts)

  1. VaamYob
    Member
    Posted 8 years ago #

    carnold, this only works on WP 2.0

    Truth, I'm planning on using AJAX for asking questions, I just stuck that there to provide functinality.

    jwurster, it's only showing approved, but if you go to the admin->options->faq page, you can approve the questions.

  2. Truth
    Member
    Posted 8 years ago #

    right, but at the moment

    when I click on submit qn, it shows
    "Thank you for asking.
    Once the admin has approved your question, it will show up in the FAQ.
    Click here to return to the FAQ"

    but on a blank white page without the layout etc. how can I make the header and footer show up as well? thanks

    i found this line

    require_once('../../../wp-blog-header.php'); on the faq_Ask.php but I don't know why is not showing up

  3. carnold
    Member
    Posted 8 years ago #

    Yes, sorry to mention, i have WP 2 installed and working

  4. VaamYob
    Member
    Posted 8 years ago #

    All, I've fixed the issue with not being able to ask a question if you are not a member.

    Truth, that line is not the line that shows the theme header, that's the wordpress common/header php. So that's why there's no header showing.

  5. VaamYob
    Member
    Posted 8 years ago #

    carnold,

    Here is the file paths:/wp-admin/faq/faq_admin.php
    /wp-content/plugins/faq/faq.php
    /wp-content/plugins/faq/faq_ask.php
    I have chmod'ed permissions on all the files. The plugin shows up in the admin panel and will activate but when nav'ing to "options"->FAQ, i get the above error.

    you have to put the faq_admin.php in the wp-content/plugins/faq/ directory (where it originally was)

  6. jwurster
    Member
    Posted 8 years ago #

    Everything seems to be working now. Yaba daba doo! Thanks again for your help. And, to let you know, it works in WP 1.5.2.

    Let's say you have 100 FAQs. Will they all appear on the Options-FAQ page or is there a way to have only 5 or 10 displayed at a time, with a next/previous?

    You know, this plugin is somewhat like some quiz and test php scripts I've looked at.

  7. VaamYob
    Member
    Posted 8 years ago #

    Paging is not planned, but with the inclusion of categories, the impact of not having paging is lessened.

  8. VaamYob
    Member
    Posted 8 years ago #

    jwurster, I just noticed that you're using the rin theme too ?

  9. jwurster
    Member
    Posted 8 years ago #

    Yes, that's my favorite 3-column theme.

  10. Truth
    Member
    Posted 8 years ago #

    Great, I got it working great already.

    Just a few questions:

    - Is it possible to let the after-submitting-question text, the thank you .... to appear on the same page instead of directing to wp-content/plugins/faq/faq_ask.php?

    - Highlighting the non-approved questions on the FAQ options page so that it's easier for us to see which questions are newly submitted etc?

    Thank you for the great plugin :)

  11. VaamYob
    Member
    Posted 8 years ago #

    Truth,

    The latest version now has the ability to notify you via email if a new question is asked by someone who is NOT LOGGED IN.

    Also, non-approved Questions are highlighted to distinguish them from already approved ones.

    Finally, the Question management has been moved to you guessed it, the Manage menu.

  12. Truth
    Member
    Posted 8 years ago #

    Thanks VaamYob for the great plugin, tested it and everything is working great :)

  13. VaamYob
    Member
    Posted 8 years ago #

    Just updated, the FAQ is now a top level admin menu option, with "Manage", "Awaiting Approval(3)", and "Options" sub-menus.

    Also, the "Ask a Question" form now does not navigate to that hack of a "thank you for asking" page.

    Enjoy !

    http://www.xyooj.com/blog/frequently-answered-questions

  14. Truth
    Member
    Posted 8 years ago #

    Right.. updated.. an error..

    at the waiting approval page


    Warning: Invalid argument supplied for foreach() in /home/huaian/public_html/liberta/wordpress/wp-content/plugins/faq/faq.php on line 175

    Edit: There is this error only when there are no questions for approval.

    Not too fond of the iframe either, is it possible to redirect to the faq page after submitting?

    thanks :)

  15. VaamYob
    Member
    Posted 8 years ago #

    ok, I bit the bullet and am now using AJAX for asking questions, also fixed the issue with the foreach error if no questions need approval.

    http://www.xyooj.com/blog/frequently-answered-questions

  16. Truth
    Member
    Posted 8 years ago #

    some questions abt this...

    I updated to the latest version but the ajax is not working for me. From your faq, I see that it render some java code but mine doesn't. Any idea what it's not working? thank you

  17. VaamYob
    Member
    Posted 8 years ago #

    yeah, I've written quite a few plugins and alot of the code can be shared. So I've created a xyooj.com directory for putting that shared code. It shouldn't show up in WP as a plugin.

    I'll update my FAQ to answer your question.

  18. Truth
    Member
    Posted 8 years ago #

    I think I edited my post just as you post..

    "I updated to the latest version but the ajax is not working for me. From your faq, I see that it render some java code but mine doesn't. Any idea what it's not working? thank you"

    And I put the folder in the plugins folder too so it should be at the right place but I've no idea why it's not working.

    Any idea?

    thank you VaamYob

  19. VaamYob
    Member
    Posted 8 years ago #

    where's the url to your faq ?

  20. Truth
    Member
    Posted 8 years ago #

    http://liberta.espoireve.com/essence/questions/

    here..

    thank you for looking into this :)

  21. VaamYob
    Member
    Posted 8 years ago #

    There could be 2 issues:
    1. you're not using the latest of the plugin
    2. your permalink structure is messing up the request for
    http://liberta.espoireve.com/wp-content/plugins/xyooj.com/ajax.js

    If it's 2, I can change the plugin to embed the js in the html instead of simply refering to it in the html.

  22. Truth
    Member
    Posted 8 years ago #

    The latest version is downloaded from your site right? with the extra folder? If yes, I think it's the latest?

    If it's 2 any idea how to fixed that? Thank you.

  23. VaamYob
    Member
    Posted 8 years ago #

    Now allows you to assign a question to a WP category.

    Will work on allowing you to limit which categories get displayed and when.

    http://www.xyooj.com/blog/frequently-answered-questions/

  24. jwurster
    Member
    Posted 8 years ago #

    Just download and got an error when I logged in to Admin that the tables wp_faq_questions and wp_faq_answers already existed. You may want to put in a check for this.

    It also gave me a bunch of warnings like:

    Warning: Cannot modify header information - headers already sent by (output started at /home/xxxxxx/public_html/wordpress/wp-includes/wp-db.php:98) in /home/xxxxxx/public_html/wordpress/wp-login.php on line 11
    WordPress

    But everything was fine when I logged in again.
    Great job.

  25. carnold
    Member
    Posted 8 years ago #

    Downloaded and extracted to wp-content/plugins and admin panel would not load. Also could not get to the website. Deleted the new faq and copied the last one back, now admin panel and web site works. Got these errors:
    Warning: main(/srv/www/htdocs//wp-content/plugins/xyooj.com/common.php): failed to open stream: No such file or directory in /srv/www/htdocs/wp-content/plugins/faq/faq.php on line 30

    Fatal error: main(): Failed opening required '/srv/www/htdocs//wp-content/plugins/xyooj.com/common.php' (include_path='.:') in /srv/www/htdocs/wp-content/plugins/faq/faq.php on line 30
    Backups are your friend:)

  26. VaamYob
    Member
    Posted 8 years ago #

    carnold,

    The xyooj.com directory (in the zip file) contains common code across some of my plugins. Did you forget to copy it up into the plugins directory on the server ?

  27. VaamYob
    Member
    Posted 8 years ago #

    jwurster,

    Those errors are probably because the plugin relies on some WP functions to update its tables. It's not supposed to, but the WP function do echo error messages during the update.

    No harm though, just disheartening to see.

  28. Truth
    Member
    Posted 8 years ago #

    Hi VaamYob, is there anyway to fix that issue of mine?

    My wordpress is in a folder called wordpress, is there a way I could get the js embeded into the html instead? Thank you :)

  29. katie1
    Member
    Posted 8 years ago #

    I uploaded your plugin and received these errors:

    First error occured after installation, when I created a faq page and viewed it:

    Warning: Invalid argument supplied for foreach() in /home/xxx/public_html/test/wp-content/plugins/faq/faq.php on line 227

    The second error occured when I wrote a mock question, hoping to remove the first error:
    WordPress database error: [Unknown column 'Array' in 'field list']
    INSERT INTO wp_faq_questions2cat (q_id, cat_id) VALUES (Array, 1)

    I approved the mock question, refreshed, and viewed the faq page and all errors disappeared.

    Thanks for a really great plugin.

    It would be nice to have the ability to turn off Category allocation on a per question basis if one didn't want to allot a particular question to any one category.

    just a suggestion. Otherwise, thanks heaps.

  30. VaamYob
    Member
    Posted 8 years ago #

    Truth,

    Can you try the latest version please ?

    Katie1,

    I'll see what the problem is. Thanks for reporting it to me.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags