WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Optimizer
[resolved] Fancybox Setting / Picture in Article (5 posts)

  1. fredel
    Member
    Posted 1 year ago #

    Hey Mark,

    me again :) I inserted a Picture via NGG Code ([singlepic id=2371 w=320 h=240 float=left] ) in an article http://bergtour-online.de/testberichte/outdooruhrennavigation/suunto-ambit-elementum-core-vergleichstest/

    Somehow there is much room between the H1 and the picture, (a myfancybox) - Also, there a blank line on top of the text.

    Do you have any idea how i can fix this (no extra space) ?

    thx so much,
    fritz

    http://wordpress.org/extend/plugins/nextgen-gallery-optimizer/

  2. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Fritz,

    I've been testing your source, and it appears this may be another issue with your theme. It seems to be adding several <br /> line breaks at the end of each line in NextGEN's HTML output. When I remove these manually, your formatting displays as it should.

    I've had a look in your theme's functions.php file (which was responsible for the title-stripping issue last time), but to no avail, I'm afraid. However, you might like to try opening up your singlepic template at wp-content/plugins/nextgen-gallery/view/singlepic.php, and put the entire anchor tag structure on one line. Eg...

    <a href="<?php echo $image->imageURL ?>" title="<?php echo $image->linktitle ?>" <?php echo $image->thumbcode ?> ><img class="<?php echo $image->classname ?>" src="<?php echo $image->thumbnailURL ?>" alt="<?php echo $image->alttext ?>" title="<?php echo $image->alttext ?>" /></a>

    Doing this removed the first two line breaks for me on my dev site, and if you also start your text immediately after the shortcode in your post editor, may remove the third also.

    Hope this helps!

    Cheers,
    Mark.

  3. fredel
    Member
    Posted 1 year ago #

    hey mark, thank so much!

    unfortunately there ist already this code in the singlepic.php

    or am i wrong?

    thx so much :)

    <?php if (!defined ('ABSPATH')) die ('No direct access allowed'); ?><?php if (!empty ($image)) : ?>
    imageURL ?>" title="<?php echo $image->linktitle ?>" <?php echo $image->thumbcode ?> >
    <img class="<?php echo $image->classname ?>" src="<?php echo $image->thumbnailURL ?>" alt="<?php echo $image->alttext ?>" title="<?php echo $image->alttext ?>" />

    <?php if (!empty ($image->caption)) : ?><span><?php echo $image->caption ?></span><?php endif; ?>
    <?php endif; ?>

  4. fredel
    Member
    Posted 1 year ago #

    uhmmm mark, you are my men! :) goot it right now, the secret was the "one line"

    thx so much again!

  5. Mark Jeldi
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Fritz,

    No worries. I'm glad that helped. It's looking much better! :)

    All the best as always,
    Mark.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic