WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Fancybox not working after Update (8 posts)

  1. Julius35
    Member
    Posted 4 months ago #

    Hi, I updated the Gallery (2.0.59) and now the Fancybox does not work any more. I found that the css is included in the page but the javascript is not. The class for the images is, as far as I can see, inserted correctly. Is there a way to make Gallery include these Scripts? I tried with other lightbox effects and none of them is working. <?php wp_head(); ?> is there in the header template. I use an own template which is pretty much standard.

    https://wordpress.org/plugins/nextgen-gallery/

  2. andreasgregor
    Member
    Posted 4 months ago #

    Same problem here.

  3. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @Julius35 - That is a very odd issue. Have you tried using the Reset Option under Gallery > Other Options ... it should put these JavaScript paths into the advanced options panel:

    photocrati-lightbox#fancybox/jquery.easing-1.3.pack.js
    photocrati-lightbox#fancybox/jquery.fancybox-1.3.4.pack.js
    photocrati-lightbox#fancybox/nextgen_fancybox_init.js

    If not, you should be able to copy and paste those paths into your settings.

    - Cais.

    PS: Using the Reset Option would set the Lightbox Effects back to the default Fancybox as well. C.

  4. andreasgregor
    Member
    Posted 4 months ago #

    I reset the options (although the paths were there before, too).
    I also loaded these scripts in my header "by hand".

    All I get is" Uncaught ReferenceError: nextgen_lightbox_settings is not defined "

  5. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @andreasgregor - I would suggest creating you own topic rather than using someone else's as the suggestions offered for them may not apply to your specific site.

    Thanks!

    - Cais.

  6. andreasgregor
    Member
    Posted 4 months ago #

    But Julius35's description fits my problem 100% and I'm of course not saying, that he (or anyone else with this problem) should not try your suggestion.
    I'm only trying to help by sharing my experience.

    Do you want me to start a thread of exactly the same topic anyways?

  7. Julius35
    Member
    Posted 4 months ago #

    @Cais Thank you very much, I tried this but it did not make the fancybox work. I was then looking for a conflict with another plugin. After deactivating one after another, I found out that it is the WP Minify. I re-activated it and unchecked the "Enable HTML-Minification" (JavaScript Minification also unchecked as it never worked in my install, so only CSS-Minification was left). With this the Fancybox was working.

    Thanks a lot for help
    Julius

  8. photocrati
    Member
    Plugin Author

    Posted 4 months ago #

    @andreasgregor - If you are using the same physical server with the same theme and plugins then I would suggest you may have a point with carrying on, but you appear to be describing a different issue which is why I recommend (and so do the forum rules and guidelines) you start a new topic for your specific issue.

    @Julius35 - Great to read you sorted out the issue. Unfortunately many minify plugins, or those plugins that offer a minify functionality, tend to create issues with NextGEN Gallery. It's also interesting to note, it appears to only be (in your case) the HTML minify option that caused the issue. Thanks for that tip!

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic