WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Fancybox being thrown to the top of the page (7 posts)

  1. dyerdesigns87
    Member
    Posted 4 months ago #

    I got my fancybox iframe to work correctly but it keeps opening the box at the top of my page. The link that uses the fancybox is in the footer of my page - how can I get the fancybox to open where the page stands?? My guess is this is an easy fix but for some reason I can't seem to figure it out.

    Any help is appreciated!! :) Thank you.

    https://wordpress.org/plugins/easy-fancybox/

  2. RavanH
    Member
    Plugin Author

    Posted 4 months ago #

    Hi, the lightbox should be opening 'where the page stands'... clearly there is something going wrong. Can you share a link to your site?

  3. dyerdesigns87
    Member
    Posted 4 months ago #

    Yeah, thats what I thought too... hmm... Here is the link. Thank you!

    http://www.justritecomfort.com

  4. dyerdesigns87
    Member
    Posted 4 months ago #

    P.S The links are on the bottom - 'privacy policy' is one working example of whats happening.

  5. RavanH
    Member
    Plugin Author

    Posted 4 months ago #

    Wow, that's a funny effect you don't see every day. Looks like a conflict with another script or style rule (or both) but hard to debug. But it's not a real surprise there is a conflict occurring on a site so heavy with all kinds of overlapping scripts.

    Could you temporarily switch off all theme effects like Responsive Slides, Revolution Slider, jCarousel, MFN Offer Slider and disable the plugin WP Supersized? Then check again if the issue remains...

  6. dyerdesigns87
    Member
    Posted 4 months ago #

    Omg youre awesome! I deactivated WP Supersized and voila! Fixed! Thank you thank you!

    By chance, do you happen to know why my background is appearing in every browser besides Safari? Just thought I'd ask since you seem pretty good with this stuff.

  7. RavanH
    Member
    Plugin Author

    Posted 4 months ago #

    Hi, indeed I narrowed the issue down to the script /wp-content/plugins/wp-supersized/js/jquery.animate-enhanced.min.js?ver=0.75

    If there is any way to prevent inclusion of that script in the Supersized options, then use that. If not, you might try to choose the Fade transition effect on Settings > Media.

    In all cases, disable all effects and sliders that you do not actually use because they make the site very heavy.

    By the way, I have not seen any backgrounds appearing during my tests. I used the Chromium and Opera browsers. But I saw no obvious script errors either so cannot say why it would not work... Maybe the same conflict with the easing script?

Reply

You must log in to post.

About this Plugin

About this Topic