WordPress.org

Ready to get started?Download WordPress

Forums

Easy FancyBox
[resolved] Fancybox and multi page Gravity Forms (10 posts)

  1. drew173
    Member
    Posted 1 year ago #

    Hello -

    I am trying to get my fancybox to work with the previous and next buttons in a gravity form - right now if I click the next button the fancybox is closed and page 2 of the form opens in a normal window.

    I have the development version installed, I've been trying every combo of iframe, hidden, inline, etc. Help me out?

    http://wordpress.org/extend/plugins/easy-fancybox/

  2. drew173
    Member
    Posted 1 year ago #

    Oh yeah -

    http://www.sacmusicmachine.com/wedding-planning-form/

    It's the "click here to get started" link right under the orange text.

  3. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, that link is to a private page. Could you set it public for a short while so I can take a look?

  4. drew173
    Member
    Posted 1 year ago #

    Hi,

    This is a live site and I've settled without FancyBox because I couldn't get it to work seamlessly.

    I would state the issue plainly like this: If you configure any multipage gravity form, there is no way to pop it in a FancyBox and have it remain in the FancyBox when you click the "Next" button - you are returned to the form on the page, not in a modal. An iFrame *may* solve this problem but that introduces its own set of styling issues and is a whole other rabbit hole - I was never able to get it to work right. You should be able to reproduce this problem easily by making a 2-page test form and using the standard fancybox-hidden, fancybox-inline classes for the form. First page pops in the modal, form looks great, you lose the modal when you go to the next page - you are correctly progressed to the next form page, but on the parent wordpress page that launched the form, not in the modal, which closes upon clicking next and causes a page refresh. Should be pretty easy to test. As I'm dealing with a fairly long form, even though modal popups are sexy and awesome, it doesn't do too good to have one that goes 3 page lengths below the fold.

    Trying to get a business off the ground and I have too many irons in the fire. I apologize for making a support request and not having the wherewithal to see its testing through to issue resolution. Hopefully this is a clear enough description of the problem. Clicking next on a multipage Gravity form refreshes the page, which closes the FancyBox modal.

    Cheers, and thank you for replying to me.

  5. RavanH
    Member
    Plugin Author

    Posted 1 year ago #

    Hey, I understand completely. No problem.

    I've added the gravity forms tag to this thread, maybe someone with the gravity forms plugin (I don't have it) can say something meaningful about it...

    Thanks for reporting in any case :)

  6. myhero
    Member
    Posted 10 months ago #

    Hi,

    I have the same issue, the fancy box closes after clicking the next / previous buttons on a multi-page form.

    RavanH, have you managed to find a solution to this issue?

  7. RavanH
    Member
    Plugin Author

    Posted 10 months ago #

    Hi myhero, no I have not found anything or heard any solution for this. If the gravity form refreshes the page when hitting Next then there is nothing that can be done to prevent the fancybox from closing. The only way around that would be to display the form in iframe mode but that would mean you have to set up a stand-alone page with form or a page template in your WordPress theme that does not include the usual header/menu/sidebar/footer stuff...

  8. myhero
    Member
    Posted 10 months ago #

    Hi,

    Thanks for the response, great plugin, a shame about the multi-page form but am also using it for other short-code functions, and it works very well.

    Thanks

  9. RavanH
    Member
    Plugin Author

    Posted 10 months ago #

    Actually, I was under the impression Gravity Forms loaded multi-page forms via ajax without the need to refresh the web page... Is that not the case? Or is that an option maybe?

  10. myhero
    Member
    Posted 10 months ago #

    I thought I'd enabled it but I didn't! Thanks for getting back to me. Problem Solved!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic