WordPress.org

Ready to get started?Download WordPress

Forums

Fancy URLs (8 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    I want my archives to appear in mywebsite.com/archives/; I want my categories to be in something like mywebsite.com/categories/, and instead of having my permalinks link like index.php?id=#ofentry, I want it to be an equally user-friendly URL, like mywebsite.com/archives/name-of-entry or something like that.
    How do I go about doing all this?

  2. Stevarino
    Member
    Posted 10 years ago #

    If your host runs apache, try creating a file called ".htaccess" (no quotes or extension) in the same directory as your weblog. Then in the admin panel, click options and then permalinks. Set those options and then copy the code you recieve into your .htaccess file.
    Not sure if you have apache or are allowed a .htaccess file? Try it anyway. :)

  3. pezastic
    Member
    Posted 10 years ago #

    I'm not Anon, but I tried this and all my image link paths got skrewed up.
    Here was a link before: "http://mysite.com/wordpress/index.php?m=200212"
    It was changed to: "http://mysite.com/wordpress/archives/2002/12/"
    Here was an image link on that page before: "http://mysite.com/images/image.gif"
    It got changed to: "http://mysite.com/wordpress/archives/2002/images/image.gif"
    The entry content was okay, but none of the images on the page showed up. Of course, that is due to their paths getting changed.
    What caused this and, more importantly, is there any way to remedy it?

  4. pezastic
    Member
    Posted 10 years ago #

    I did that and mod_rewrite is in the loaded modules box. I tried both:
    /archives/%year%/%monthnum%/%day%/%postname%/
    and
    /index.php/archives/%year%/%monthnum%/%day%/%postname%/
    and applied their respective codes generated in a .htaccess file (with nothing else) located in the wordpress directory. Both produced undesirable results like I mentioned previously.

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    Hello
    Ok, Stevarino I tried what you said to do in post number 2, and it worked!!!
    BUT...
    Then when I goto a Category page the url is what I intended but all my other links are messed up. What did I do wrong?
    I am totally new to all of this, so bear with me as I may be a bit slow.
    Thanks
    Johnny

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    Hello
    If anyone ever sees this, I got it all straightened out.
    Thanks for your interest.
    Later
    Johnny

  7. pezastic
    Member
    Posted 10 years ago #

    Wait a minute, Johnny. How did you straighten it out? I have the same situation.

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    Hello
    I added this to all the links that we're messed up: <?php echo get_settings('siteurl'); ?>/whatever.php
    To be honest, I don't really understand all of this stuff, I lucked into getting it to work.
    I am glad to be of assistance if I can.
    Later
    Johnny

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.