WordPress.org

Ready to get started?Download WordPress

Forums

Fancy permalinks not showing up (11 posts)

  1. derekxyz
    Member
    Posted 7 years ago #

    The normal "page?=123"-esque permalinks work fine. But when I try the ones with the date and post name, they just don't work. Everything's broken.

    I tried blanking .htaccess, chmodding it to 777, and then switching permalink styles. It writes to .htaccess, but nothing happens.

    This is what it writes:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /pik/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /pik/index.php [L]
    </IfModule>

    # END WordPress

    When I click the Post permalinks though, it takes me back to the front page (which is apparently what happens on a 404). The same happens with all the Pages, too. It goes to /about/ in the nav bar, but nothing. Front page.

    I also know nothing about servers, so this is what I'm pulling out of my server environment page thingy:

    SERVER_SOFTWARE=Apache/1.3.34 (Unix) mod_fastcgi/2.4.2 mod_perl/1.26

    Aaand, PHP is set to version 4. I dunno what else could be the problem. Any help?

  2. Chris_K
    Member
    Posted 7 years ago #

    You'll find some trouble-shooting stuff on the Permalinks page.

    In particular, confirm with your host that mod_rewrite and AllowOverride are both on and enabled.

  3. derekxyz
    Member
    Posted 7 years ago #

    Turns out you can close this topic, too. I just found out my host (Netfirms) is notorious for not supporting AllowOverride.

    That doesn't leave me with many options, but at least it's not an error on my part. :B

  4. Chris_K
    Member
    Posted 7 years ago #

    Ack.

    Well, you can do "almost pretty" permalinks, for what that's worth. Almost just as good, but a custom string with "index.php" in it.

  5. scud
    Member
    Posted 7 years ago #

    I have a similar issue where all my older 'pages' give 404 errors now. Only even links coming from my Manage > Pages list look like they're linking ok however they give me 404 errors.

    If I put the permalink structure back to default the pages show up, but anything other than that and they're broken.

    I don't know why they'd suddenly change after doing the upgrade to 2.2 but that's the only thing that's changed recently.

  6. mettaangel
    Member
    Posted 7 years ago #

    I'm having the same problem scud is; posts work fine, as do category listings, etc., but all existing static pages go 404 unless I'm using the default permalinks. Help?

  7. mettaangel
    Member
    Posted 7 years ago #

    Please help?

  8. punkoblog
    Member
    Posted 6 years ago #

    I am having this same issue. Anyone have an idea?

  9. Hilgert
    Member
    Posted 6 years ago #

    Yes I had the same problem, but thanks to my hosting provider it has been fixed. It wan't the mod_rewrite or AllowOveride though:

    This was the error as it appeared in the server log:
    [Tue Nov 13 11:12:40 2007] [error] [client 62.148.189.18] ALERT - use of eval is forbidden by configuration (attacker '62.148.189.18', file '/var/www/vhosts/acme.com/httpdocs/wp-includes/classes.php', line 108)
    [Tue Nov 13 11:12:40 2007] [error] [client 62.148.189.18] PHP Fatal error: SUHOSIN - Use of eval is forbidden by configuration in /var/www/vhosts/acme.com/httpdocs/wp-includes/classes.php(108) : eval()'d code on line 108

    They use Suhosin to secure PHP. It has been solved by setting the php_admin_value suhosin.executor.disable_eval to 0.

  10. depperson
    Member
    Posted 6 years ago #

    I don't know about anyone else, but I was also having trouble with Permalinks with my host provider, Netfirms.

    I checked their support site and found this and now my Permalink structue (date and name based) works!

    Happy tweaking!

  11. depperson
    Member
    Posted 6 years ago #

    Forget my previous post; apparently it worked for a short period of time and now I am back to each link sitting at the home page.

    Back to ugly URLs for me!

Topic Closed

This topic has been closed to new replies.

About this Topic