WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] Fancy notification not showing (10 posts)

  1. Janusz-gadzety
    Member
    Posted 8 months ago #

    I install new version of wordpress (3.7.1) and wp-ecommerce 3.8.12.1 and fancy notification after click add to cart not working.
    Nothing change in files.

    Maybe someone find solition for that?

    http://wordpress.org/plugins/wp-e-commerce/

  2. jtm12
    Member
    Posted 7 months ago #

    Same problem for us. In fact, with that upgrade, we noticed four changes to our wp e-commerce store:

    1) Fancy notifications have disappeared.
    2) The variations price display no longer works as far as the price changing when someone selects a variation.
    3) Formerly, when someone clicked "More details," the details showed in that window. Now, the person is taken to a single product page.
    4) Formerly, when someone put a product in the cart, the fancy notification showed, and the buyer could decide whether to keep shopping or check out, but the buyer stayed on that same page. Now, when someone puts a product in the cart, the buyer is taken to the single product page for the item put in the cart, though logically, that buying decision was already made, so why go to the single products page now?

    These are all fairly major changes in user experience for our customers.

    I am somewhat new to the plugin world, so I guess I would ask:
    Do plugins just keep changing like this, so each time one upgrades, one doesn't know what to expect?

    I have been an enormous fan of WordPress and the plugins. But I don't know what to think with this latest development. Upgrading the software shouldn't create the same trepidation as driving in snow.

  3. Mihai
    Member
    Plugin Author

    Posted 7 months ago #

    AS you can see in the changelog http://wordpress.org/plugins/wp-e-commerce/changelog/ there are no changes that affect that behaviour.
    Most likely you have a javascript/jquery issue since updating.

    Try it in the default wordpress theme.
    Someone mentioned the same issue with the variations price but i tested on a brand new setup using just WPEC and default wp theme and it works fine so its most likely a theme issue or even maybe a plugin conflict.

    Regards
    Mihai

  4. missodessa
    Member
    Posted 7 months ago #

    my blog is on 3.7.1 I updated my wp ecommerce to the latest version today and am experiencing the same problem. I disabled all of my plugins went back to default theme...same issue.

    I reverted back to the old version of wp ecommerce from a backup and it's working fine but then I had an issue with adding products so I went back to the lastest version of wp ecommerce.

    I did play around with core files and noticed that when I replace the wp-e-commerce.js with the one before the upgrade. The fancy box will at least display but it gets stuck with a message that says "updating"...it has to be something in the upgrade coding as it is not a theme or plugin issue conflicting with the coding.

    I haven't been able to figure it out yet either but maybe someone can take a look at that file and figure it out.

  5. Dan Milward
    Member
    Plugin Author

    Posted 6 months ago #

    @Janusz-gadzety @missodessa

    Can you please try using 3.8.13 and confirm that this is still an issue. We can't help fix this problem unless we have access to the sites in question. Hopefully they are resolved but its hard to say.

    The best most helpful way is to post the question to our premium support team. That way we have access to the sites and themes in question. We can be more useful :)

    getshopped.org/resources/premium-support/

    Best,
    Dan

  6. saturnamjp
    Member
    Posted 6 months ago #

    It's still an issue, even with Version 3.8.13.1. This started happening to me with the latest WordPress upgrade so it started before 3.8.13 if I recall correctly. I disabled my store page back in November when this first occurred and have yet to resolve it. Some help would be nice.

  7. saturnamjp
    Member
    Posted 6 months ago #

    Ok, I just changed themes and the notification worked and then switched back to my original theme and the notification is still working. So, problem is resolved for me.

  8. snw1407
    Member
    Posted 5 months ago #

    I have this same issue. I am working off WordPress 3.8 and I have the latest WP E-Commerce and Gold Cart plugin. I am using the "Awake" theme by MySiteMyWay and disabling the theme and using the default wordpress theme makes it so the fancy notifications appear, but switching back to my original theme makes them hidden again.

    I never had this problem on previous versions, and I do not have the luxury of easily switching themes. Is there any thoughts about what specifically could be hiding the plugin? I can't quite see what the error is.

    Thanks!

  9. snw1407
    Member
    Posted 5 months ago #

    Nevermind. I didn't know there was an update on my theme because it is a themeforest theme but there was and this fixed the problem.

    Sorry for the post!

  10. nalves
    Member
    Posted 4 months ago #

    Hi,
    Since the last update the fancy notification stopped working on this site bibs.pt.
    I've tryed changing the theme to TwentyThirteen and the notifications work...any ideas on how to solve this?

    WP Version: 3.8.1
    WPEC: 3.8.13.3
    Theme Based on WP-Bootstrap from 320Press

Reply

You must log in to post.

About this Plugin

About this Topic