WordPress.org

Ready to get started?Download WordPress

Forums

P3 (Plugin Performance Profiler)
False Positives (3 posts)

  1. bamajr
    Member
    Posted 1 year ago #

    Akismet and P3 are the only plugins installed/active, yet P3 insists I have 3 plugins installed.

    http://wordpress.org/extend/plugins/p3-profiler/

  2. Kurt Payne
    Member
    Plugin Contributor

    Posted 1 year ago #

    Hi bamajr,

    P3 is counting mu-plugins, too. When you activate P3, it installs an mu-plugin to load early (before normal plugins) so the profiling data is more accurate. When you deactivate P3, it removes the mu-plugin. If you want to see this file yourself, visit your wp-content/mu-plugins folder and look for p3-profiler.php.

    For more information on mu-plugins, see the codex here:
    http://codex.wordpress.org/Must_Use_Plugins

  3. bamajr
    Member
    Posted 1 year ago #

    @Kurt Payne...

    Thanks for your response. As a custom plugin developer, I fully understand what "Must Use" plugins are and why plugins may, or may not have that designation. Based on your answer, I'll change my "Broken" designation to "Works" instead, but your answer brings up other questions.

    1. Why aren't MU Plugins counted in the "ALL" plugins total, by the WordPress core? I know this is probably more of a WordPress Core question, but I thought I'd bring it up here first, since it seems like it should be directly related.

    2. Why doesn't the P3 Profile the MU Plugin, separately from the general plugin? If P3 is going to identify an additional MU Plugin, it should profile the MU plugin, separate from the main plugin, don't you think. In other words: If Akismet and P3 are the only plugins installed/active and P3 insists I have 3 plugins installed, why doesn't the P3 profiler, identify the MU Plugin separately, in reporting its statistics?

    Oh, side note (FYI): I was very careful to select the current version of WordPress, when I submitted this post. Yet, looking at the right column, the WordPress version is INCORRECTLY identified as 3.3.1 when I chose, 3.5

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic