WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] False Error, dead stop. "Username must be at least 4 characters" (7 posts)

  1. DougJoseph
    Member
    Posted 2 years ago #

    I (as admin) have been unable to created a new user. The username is more than 4 characters, but it is being rejected with the error message "Username must be at least 4 characters." I then switched to a different browser (from FF to Chrome). I cleared the browser cache on Chrome, and on the first try on Chrome I got the same error. Since the username is more than 4 chars, I have no way to correct this. Since I switched browsers entirely, it cannot be a browser cache issue. I cleared the cache of Chrome before starting anyhow, just to be sure. Desperately need help on this. Anyone know? I either need to get this working, or find a plugin or script that allows me to actually create users.

  2. DougJoseph
    Member
    Posted 2 years ago #

    I also need to be able to create users who have a dash (hyphen) in their username.

    I have searched for a plugin to tweak the restrictions on usernames. No luck yet.

    I found a script someone posted a year ago, but the topic is closed, and the thread does not say where to place the script. Can anyone help me?

  3. DougJoseph
    Member
    Posted 2 years ago #

    I seem to have found an issue that let me solve this. Long ago, in my search to address the restriction that prevents dashes, I had installed a plugin called "Network Username Restrictions Override."

    I was unaware that it had a settings page, and it seems that installing it without adjusting its settings, may have been my current issue.

    I found the link to edit its settings, did that, and now I can add members, and can even add usernames that have hyphens.

    Hope this helps someone else.

  4. Ovidiu
    Member
    Posted 2 years ago #

    same problem here but your solution didn't work.
    deleted said plugin but still cannot create any users.
    always getting the warning about 4 characters long user names.

    any other suggestions?

    yes, user registration and blog creation is both allowed.

  5. DougJoseph
    Member
    Posted 2 years ago #

    My solution was not to delete the plugin but to use it properly.

  6. Ovidiu
    Member
    Posted 2 years ago #

    Fixed my problem by deleting both plugins:

    http://wordpress.org/extend/plugins/network-username-restrictions-override/ and
    http://wordpress.org/extend/plugins/wpmu-blog-name-restrictions-override/

    one of those must have fixed the problem.

    @ DougJoseph: Not sure how to understand your comment. Did you read mine? I said:

    same problem here but your solution didn't work.

  7. DougJoseph
    Member
    Posted 2 years ago #

    I misunderstood. I gathered an implication that you thought my solution was to delete the plugin. Glad you found a way to make it work.

Topic Closed

This topic has been closed to new replies.

About this Topic