WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] False categories sitemap entry (3 posts)

  1. trexagyreve
    Member
    Posted 1 year ago #

    Hello Joost,

    In my /category-sitemap.xml I noticed that the last entry is a post URL, not a category URL.
    This same post is as normal included -also- in the /post-sitemap.xml
    This post belongs to a category that has only one post, the one in question.
    This category is as expected mentioned in the /category-sitemap.xml only once but -and that's the problem- just as part of its unique post URL.
    This category has no child category; it has one parent category.
    In other words, in my /category-sitemap.xml there is a false entry "/category/post" instead of "/category/" for a category that has just one post, one parent category and has no child category.
    (
    WPSEO version 1.3.1.1
    Strip the category base: enabled
    URI structure: /%category%/%postname%

    )

    Thank you.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Heh, that's a weird bug. Could you try and reproduce in the latest version? (I just updated it)

  3. trexagyreve
    Member
    Posted 1 year ago #

    Just updated to the latest version, but the weird problem persist.
    Opa! Just got it!
    It's just that some time ago I had the idea to set a rel canonical on this category pointing to the its unique post (seemed like a possible duplicate issue to me: a category page with its posts abstracts having much similar content with its unique post).
    I removed the canonical and now the sitemap is OK.
    I wonder, however, was this a correct behavour of your plugin?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic