WordPress.org

Ready to get started?Download WordPress

Forums

Failed upgrade to 2.9.2 (12 posts)

  1. FlyingPodcast
    Member
    Posted 4 years ago #

    Hi
    I just tried to upgrade to 2.9.2.
    I am a relative newcomer to this so please bear with me.
    Following the extended upgrade instructions I deleted the recommended files.
    I downloaded the 2.9.2 files and, from there, uploaded WP-Admin, WP-Includes and WP-Content (plug-ins & themes).
    When I tried to go to my dashboard page I got the following error messages:

    Warning: main(/homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/streams.php) [function.main]: failed to open stream: No such file or directory in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-settings.php on line 273

    Warning: main() [function.include]: Failed opening '/homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/streams.php' for inclusion (include_path='.:/usr/lib/php') in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-settings.php on line 273

    Warning: main(/homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/gettext.php) [function.main]: failed to open stream: No such file or directory in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-settings.php on line 274

    Warning: main() [function.include]: Failed opening '/homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/gettext.php' for inclusion (include_path='.:/usr/lib/php') in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-settings.php on line 274

    Fatal error: Cannot instantiate non-existent class: noop_translations in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/l10n.php on line 437

    The above mean absolutely nothing to me. Can anyone let me know where I went wrong?

    Luckily I had done a full back up... phew!

    Cheers

    Steve

  2. Samuel B
    moderator
    Posted 4 years ago #

    do you normally have 2 wordpress folders or did you accidentally upload the entire worpress folder inside the other wordpress folder instead of just the files/folders inside the zip wordpress folder?

  3. FlyingPodcast
    Member
    Posted 4 years ago #

    Hi
    I didn't have the 2 wordpress folders on purpose. So I guess I wrongly uploaded one WP folder into another WP folder. Does that sound like my problem?

  4. Samuel B
    moderator
    Posted 4 years ago #

    Does that sound like my problem?

    yes it does

  5. FlyingPodcast
    Member
    Posted 4 years ago #

    OK I'll have another go. Thanks for the speedy response.
    Steve

  6. FlyingPodcast
    Member
    Posted 4 years ago #

    Hi

    I've justhad a check on how my current set up looks on the remote server.
    Here's how it's set up at the moment. This set up work OK using 2.7.1.
    Are you saying that I need to get rid of the WP folder within another WP folder for my upgrade to work correctly?

    - /
    - logs
    - WordPress
    - wordpress
    - wp-admin
    - wp-content
    - wp-includes

    Steve

  7. I'm assuming you mean it looks like this:

    - /
    - /logs
    - /Wordpress
          - wordpress
               - wp-admin
               - wp-content
               - wp-includes

    Which, yeah, that should be fine, but you'll be accessing WP from:

    http://domain.com/Wordpress/wordpress

  8. FlyingPodcast
    Member
    Posted 4 years ago #

    Yes that is the layout I currently have.
    I tried to upgrade to 2.9.2 using this layout and I got the list of errors listed above. Samboll said that I was using 2 wordpress folders and that was what was causing my problem.
    I don't now understand what you are saying. Sorry but I am very much a newcomer to this.

  9. Having WordPress in a subfolder shouldn't make a whit of difference.

    The error you're getting basically says 'I can't find /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-settings.php so I can't process your request.'

    In your WordPress/wordpress/ folder, do you have a wp-settings.php file?

  10. FlyingPodcast
    Member
    Posted 4 years ago #

    I'm just trying to upgrade again now.
    I've deleted the wp-admin and wp-includes folders and replaced them with the 2.9.2 folders in the same place.

    I just clicked on my Dashboard and get the same errors as above.

    I do have a wp-settings.php file in my WordPress/wordpress folder.

    I haven't done anything with the wp-content uploads yet.

    Also, I do appear to have the WordPress/wordpress/wp-includes/l10n.php file too which is mentioned in the 'fatal error'

    I don't know whether this is relevant but I don't have:

    WordPress/wordpress/wp-includes/streams.php

    or

    WordPress/wordpress/wp-includes/gettext.php

  11. FlyingPodcast
    Member
    Posted 4 years ago #

    Further to the above...

    I uploaded the WordPress/wordpress/wp-includes/streams.php and WordPress/wordpress/wp-includes/gettext.php files from my 2.7.1 back-up files.

    I cleared my cache and now I just get:

    Fatal error: Call to undefined function: is_admin() in /homepages/4/d278247900/htdocs/Wordpress/wordpress/wp-includes/vars.php on line 16

    I do have a WordPress/wordpress/wp-includes/vars.php file

  12. DianeV
    Member
    Posted 4 years ago #

    I'd start over. If your blog was originally at site.com/wordpress (or WordPress capitalized, for some reason), then that is where the 2.9.2 files should go -- not in site.com/Wordpress/wordpress.

    Delete the second wordpress folder (/Wordpress/wordpress), then open the wordpress folder on your computer and upload everything that's in it (all the files and folders) into the WordPress directory ... that is, don't upload the /wordpress folder into /Wordpress so that you end up with /Wordpress/wordpress again.

    Then try to run the upgrade.

Topic Closed

This topic has been closed to new replies.

About this Topic