WordPress.org

Ready to get started?Download WordPress

Forums

Failed to submit comment - 404 error (24 posts)

  1. dulotie
    Member
    Posted 4 years ago #

    Failed to submit comment. click submit will lead to 404 error- page not found.

    have tried changing themes, re-save permalinks, recheck permalinks (no space)

    What seems to be the problem?

    http://imelvin.com/

  2. Jonas Grumby
    Member
    Posted 4 years ago #

    Did you try deactivating all plugins? What about setting permalinks to Default?

  3. dulotie
    Member
    Posted 4 years ago #

    yes, it turns out the same. I even deleted un-use plugins from the ftp

  4. jimisaacs
    Member
    Posted 4 years ago #

    Does the file wp-comments-post.php exist on your server?

  5. dulotie
    Member
    Posted 4 years ago #

    it's there..

  6. jimisaacs
    Member
    Posted 4 years ago #

    What about setting permalinks to Default?

    Did you see any errors after submitting these changes within the admin?

    Do you have access to your .htaccess file? If so, and there are any contents within it, try to empty it and post the outcome.

  7. dulotie
    Member
    Posted 4 years ago #

    I don't have any problem setting permalinks back to default.
    Message showed: permalinks structure updated.
    submitting comment after that shows:

    Not Acceptable

    An appropriate representation of the requested resource /wp-comments-post.php could not be found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    This is the content within .htaccess:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    U mean update an empty .htaccess file back to the server?

  8. jimisaacs
    Member
    Posted 4 years ago #

    U mean update an empty .htaccess file back to the server?

    Yes, you can simply rename the .htaccess file to htaccess.txt then see if that that fixes the error.

  9. dulotie
    Member
    Posted 4 years ago #

    It's still the same =X

  10. Jonas Grumby
    Member
    Posted 4 years ago #

    Renaming the .htaccess file will cause Permalinks not to work and I'm not sure what the test is meant to prove. However, it seems like your error message is telling you that your theme is missing an expected file (wp-comments-post.php). Does it happen if you switch to the Default theme?

  11. dulotie
    Member
    Posted 4 years ago #

    the same problem occur. I'm trying to download wordpress again and replace the old wp-comments-post.php.

  12. dulotie
    Member
    Posted 4 years ago #

    Still no luck.

  13. dulotie
    Member
    Posted 4 years ago #

    bump

  14. Jonas Grumby
    Member
    Posted 4 years ago #

    I assumed it was looking for something in the theme but wp-comments-post.php is a core wordress file. Did you try uploading the wordpress core files from a fresh download?

  15. soul101
    Member
    Posted 4 years ago #

    I'm having the same issue. After submitting a comment, the URL goes to:
    http://mydomainname/mypostname//comment-page-1#comment-7

    and displays: "Error 404 - Not Found
    Sorry, the page that you are looking for does not exist."

    However, the comment does get saved and it can be viewed on:

    http://mydomainname/mypostname/%20/comment-page-1#comment-7

    My permalink setting is: /%postname%/

    I changed it to default and the comments are working ok, but I don't really want to change my custom permalink. What should I do? Any suggestions?

  16. Rev. Voodoo
    Volunteer Moderator
    Posted 4 years ago #

    after changing it to default, did you try going back to custom? sometimes you just have to save to default then back to cutom to reset things

  17. Jason
    Member
    Posted 4 years ago #

    Hi there!

    I was having the exact same issue, and managed to get it working again. I had an errant space at the end of the "Custom Structure" of the Permalink Settings, and it's what was causing the "//" to appear in the comment URL that you get taken to upon submission (i.e. the broken url).

    Make sure there are no spaces in that field, and it should fix it right up.

    Hope that helps!

    Jason

  18. Anton
    Member
    Posted 4 years ago #

    None of the above suggestions helped for me. Can anyone please advise me?? Thanks, i am getting pretty desperate now...

  19. Anton
    Member
    Posted 4 years ago #

    Still no advice??

  20. Jason
    Member
    Posted 4 years ago #

    Hi doordebenen

    I'm no expert, but I do know that "%20" is a substitution for a space in a URL, and it's showing up in the URL you quoted (http://mydomainname/mypostname/%20/comment-page-1#comment-7) - it means that you have a space somewhere where it shouldn't be. In my case, it was in the "Custom Structure" field. I'd suggest making doubly sure you have no spaces in any of the URL fields.

    Sorry I can't help more - I saw you having the same problem as me, and the fix I described worked like a charm.

    J

  21. jensimmons
    Member
    Posted 4 years ago #

    I was having this same problem. And it wasn't the permalink structure. The file wp-comments-post.php was missing from the server. Someone must have deleted it. Once I put a new copy there, everything is fine.

  22. ivie
    Member
    Posted 4 years ago #

    I was having the same problem yesterday. I turn the permalinks to default save it and then re-custom again as I wish. and it solved.

  23. Anton
    Member
    Posted 4 years ago #

    The problem has finally been solved. The solution was very simple. Go to settings of your comments and disable (uncheck) "break comments into pages".
    Thanks to http://www.wphulp.nl/forum/

  24. span
    Member
    Posted 3 years ago #

    SS_Minnows comment helped me greatly.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags