WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
Failed to open stream wc-core-functions.php line 100 (8 posts)

  1. Robert
    Member
    Posted 5 months ago #

    After updating to wc 2.1 (including database update) I saw two error rows on product pages, containing Failed to open stream ... wc-core-functions.php on line 100.

    Also the update adds different things I don't want, like a 'buy' button, a stock indication, etc. I removed them in the previous woocommerce version.

    Using Elegantthemes Foxy theme. Example page.

    I re-installed an older version of wc to keep the site running correctly. Please fix this!

    https://wordpress.org/plugins/woocommerce/

  2. alistairgd
    Member
    Posted 5 months ago #

    Same here, full error is

    Warning: include(/***/shop/wp-content/plugins/woocommerce/templates/shop/breadcrumb.php) [function.include]: failed to open stream: No such file or directory in /***/shop/wp-content/plugins/woocommerce/includes/wc-core-functions.php on line 100

    The problem is there is no template/shop directory in woocommerce 2.1!

  3. esmi
    Forum Moderator
    Posted 5 months ago #

    @alistairgd: It is considered impolite to interrupt another poster's ongoing thread unless you are posting a solution or suggestion. It causes significant problems for the forum's volunteers and prevents us from being able to track issues by topic. Please post your own topic.

  4. alistairgd
    Member
    Posted 5 months ago #

    Eemi, I was not posting an unrelated error, this is the same error.

    I was letting Robert know that I experienced the same error and as such he can be assured it is not something that he alone is having issues with.

    My post was not an interruption, it was a contribution and by it I hope I have helped Robert in a small manner. As you can see I pointed Robert to where the problem lies.

    I thought this was better than starting a separate thread for the same issue, if you feel this is incorrect I will start a new thread as requested.

    Apologies if this was not clear.

  5. esmi
    Forum Moderator
    Posted 5 months ago #

    These forums have guidelines. Please read them.

    As you will see, one of these guidelines - entitled Where to Post - specifically states:

    Unless you are using the same version of WordPress on the same physical server hosted by the same hosts with the same plugins, theme & configurations as the original poster, do not post in someone else's thread. Start your own topic.

    Please abide by this.

  6. CockpitSeeker
    Member
    Posted 5 months ago #

    Hi, as I also want to be able to update this plugin (I never update a plugin right off the bat, lucky bastard-me), I'm already trying to help in that thread here if that's of interest to anyone around...

    Looks like the early updaters are going to be the beta testers ;)

  7. Elegant Themes
    Member
    Posted 5 months ago #

    This is a compatibility issue with our Foxy theme you are using, which calls to the old folder structure. We are updating our themes now to accommodate for the change in file path that has occurred in WooCommerce 2.1. Stay tuned of updates, or adjust the path in functions.php of your theme manually. Just search for /shop and replace it with /global, or swing by our forums if you need more help. Thanks for the patience.

  8. Robert
    Member
    Posted 5 months ago #

    I saw there's a theme update now. Will try it later after I've made a good backup. Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic