WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Failed to open stream (6 posts)

  1. Rom
    Member
    Posted 3 years ago #

    HI, just did a manual upgrade of wp site i set up for a friend around a year ago. Now I get this error. It's installed on a subdomain on another server, lightofmorning.com is only mirroring that subdomain.

    Help is deeply appreciated. Been searching the forums for this particular version of the 'failed to open stream'-error with no luck

    Warning: require(/home/lightofmorning/www/wordpress/wp-includes/home/lightofmorning/www/wordpress/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home/lightofmorning/www/wordpress/wp-settings.php on line 19

    Fatal error: require() [function.require]: Failed opening required '/home/lightofmorning/www/wordpress/wp-includes/home/lightofmorning/www/wordpress/wp-includes/load.php' (include_path='.:/usr/share/php:/usr/share/pear') in /home/lightofmorning/www/wordpress/wp-settings.php on line 19

  2. Rom
    Member
    Posted 3 years ago #

    neither WordPress or the plugins had been updated since I set the site up - the site started to misbehave so I thought I'd update everything. However, I did deactive the plugins by renaming them before the upgrade, so they shouldn't be the reason for the error...

    anyone?

  3. Rom
    Member
    Posted 3 years ago #

    I can see here that the error is saying that load.php doesn't exist in wp-includes. I've checked, it does exist.

    I've tried to do the upgrade in steps instead (2.7>2.8>2.9>3.0). In 2.7 the error still showed, but on top of the site. In other words the site was visible but with an error text. from 2.8 and forward it's a white screen with the error text.

    I've now done multiple fresh uploads of 3.04 to make sure that it isn't a corrupted file.

    Can this be an issue with file permissions for one of the files mentioned in the error? If so, where can I find the correct permissions for those?

    I guess it's possible to rebuild the site from scratch, but that shouldn't be necessary, right?

  4. Rom
    Member
    Posted 3 years ago #

    Another update:

    I redid the manual upload of 3.04 by following the instructions here: http://codex.wordpress.org/Upgrading_WordPress_Extended + renaming my theme to make the twentyten theme active instead.

    I still get an error, but not the same one. The blog says:
    Warning: Unknown: failed to open stream: Permission denied in Unknown on line 0

    Fatal error: Unknown: Failed opening required '/home/lightofmorning/www/wordpress/index.php' (include_path='.:/usr/share/php:/usr/share/pear') in Unknown on line 0

    Other WP tools (i.e. admin & upgrade) gives the 403 Forbidden error

  5. Rom
    Member
    Posted 3 years ago #

    I changed my permissions in the entire wordpress installation according to Samuel B's recommendations here: http://wordpress.org/support/topic/what-are-correct-file-permissions?replies=3

    Now I have access to wp-admin but my public site is a blank white screen

  6. Rom
    Member
    Posted 3 years ago #

    Reactivated my theme and voila!!

Topic Closed

This topic has been closed to new replies.