WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
[resolved] Failed to install and broke 3 other plugins (5 posts)

  1. michaeldayla
    Member
    Posted 4 months ago #

    I reverted back to the last stable release. The plugin did not show up in the plugin folder and 3 other plugins (broken link checker, wp jump, and another I cannot remember right now) broke and could not be installed/uninstalled except via FTP. I will be very dubious about updating this plugin again.

    https://wordpress.org/plugins/google-sitemap-generator/

  2. arnee
    Member
    Plugin Author

    Posted 4 months ago #

    I don't see how the plugin could break any other plugin, especially how it could prevent other plugins from being uninstalled. Did you get an error message? All the installation / uninstallation is handled by WordPress, not by the plugin.

  3. michaeldayla
    Member
    Posted 4 months ago #

    Well, after the update it failed to appear in the plugin list. At the top of the plugin page was a warning that 3 plugins had been uninstalled because they caused an error. When I tried to install the uninstalled plugins, they could not be installed automatically.

    I visited the site via FTP and had to manually delete google site map plugin and the others which had caused the errors.

    I was then able to revert back to a prior stable version of google site maps and was able to reinstall the other plugins.

    I do not know how or why this happened but it happened when I "upgraded" google site maps plugin.

  4. arnee
    Member
    Plugin Author

    Posted 4 months ago #

    I've installed two of the plugins (broken link checker and WP Jump Menu) and did several tests with the sitemaps plugin, including a new installation, upgrading from 3.4, deactivation and so on, each time without any problem.

    Can you try again and if there are any errors, provide the error log information from the web server?

  5. michaeldayla
    Member
    Posted 4 months ago #

    I am reluctant to experiment now that I have the site up and running well, again. I notice that some have had problems depending on the type of server they are using. I am on DreamPress which uses a varnish preload cache. I wonder if that might be the reason the update broke those plugins and didn't appear in the plugin list after upgrade.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.